Filter Flow Weak

NBettas83

So I have had this problem with all 3 of my HOB filters (Two Top Fin Silentstreams, One Penn-Plax Cascade 80), the flow on them is great for one or two weeks, but then just slows down to the point of a drizzle. I've tried taking the impeller out and putting it back in, but nothing happens. This is getting to the point of insanity and I can't sleep as soundly anymore, please help, what is wrong?
 

BigManAquatics

How long since you cleaned the media? Or checked inside the intake tube?
 
Upvote 0

NBettas83

How long since you cleaned the media? Or checked inside the intake tube?
2 Weeks at most, I've only had it for two, It's definitely not the media.
 
Upvote 0

LHAquatics

2 Weeks at most, I've only had it for two, It's definitely not the media.
does the impeller spin?
 
Upvote 0

NBettas83

does the impeller spin?
Yes, I did a spin test and it doesn't spin as long as when I got it (if I give it a spin with my hand), unfortunately like most impellers I can't get under the actual impeller to clean it (or at least I think). It is always spinning when the filter is on.
 
Upvote 0

BigManAquatics

I can pull mine out when the filter is off. Very handy for cleaning and maintenance purposes.
 
Upvote 0

NBettas83

I can pull mine out when the filter is off. Very handy for cleaning and maintenance purposes.
Yes, but is there a way too get under the actual impeller to clean the metal bar? Mine won't move enough to directly expose the part it rests on, please, if anyone knows how I can fix this, please tell me. I would think it would be common, as it's happened to 3 of my filters. The current one is a Penn-Plax Cascade 80, forgive me for being frantic, I'm just so stressed by it.
 
Upvote 0

ForceTen

Remove the media and see if it returns to normal. Just because its only a couple weeks old does not mean its not clogged up.
I have yet to see and HOB filter that could not be disassembled so each and every part can be cleaned and inspected.
 
Upvote 0

NBettas83

Remove the media and see if it returns to normal. Just because its only a couple weeks old does not mean its not clogged up.
I have yet to see and HOB filter that could not be disassembled so each and every part can be cleaned and inspected.
Ok, I'll try that, I will see if the impeller can come off.
 
Upvote 0

Similar Aquarium Threads

  • Question
Replies
6
Views
209
Jonmott
  • Question
Replies
5
Views
187
mattgirl
  • Question
Replies
8
Views
194
Gameynerd23
  • Question
Replies
2
Views
145
Mel254
  • Question
Replies
4
Views
222
sillylittlefishey

Random Great Thread!

New Aquarium Filter Threads

Latest Aquarium Threads

Top Bottom