Yellowing plants, API root tabs

  1. Broq15 Initiate Member

    I recently had a sudden blossom of algae all in my tank bc I left town and my roommate opened the blinds for like 5 days.

    Since then my tank just has not been the same. I just did a 25-30% water change and have had to wipe off my brown algae (diatoms?) from my anubias nana and melon sword.

    My banana plant is not looking as green and healthy since I first got it...it requires low-medium light and that's what I have. Does it need fertilizer? Some of my corkscrew vals are turning yellow...what is the problem? Can anyone help?

    I just purchased API root tablets and inserted it into my gravel substrate. Was this a good buy?

    Any advice?
     
  2. Aquarist Fishlore Legend Member

    http://www.csd.net/~cgadd/aqua/art_plant_nutrient.htm
    http://3.bp.blogspot.com/_cwbt2D65i...JcdLSqSf4/s1600-h/3591814040_bc03c264a5_o.jpg

    Hello Broq. You may find the links above interesting and helpful. I don't personally have a great deal of plant experience. I do have 1 large Anubia (doing great), Java Moss growing like crazy, :) Japanese Marimo Balls also doing great. I dont do anything special as far as fertilizers or special substrate. All low light plants and my lighting in generic that came with the tank.

    Diatoms are very common in new tanks up to a year and I consider them a fact of life in this hobby :) As your tank gets more established you'll see it less and less.

    I'm sure you'll get some more responses from members with more plant experience.
    Best of luck!
    Ken