White Fuzz Growing on Plants?

noahhutch01

New Member
Member
Messages
13
Reaction score
3
Experience
3 years
A little over a week ago I purchased a fish tank and immediately began cycling the water. A few days ago I put in a few live plants. Today I am noticing a small white fuzz growing on one of the roots. I have attached a photo. What is it?? Is it safe or will it become a problem? Also, I’ve noticed that there’s a few snails crawling around. Are they going to become a problem? I’ve added a photo of them, too. My plan is to get fish whenever the water parameters indicate the tank is ready, but is there anything else I need to do to make sure this tank is safe for my plants and fish?
 

Attachments

Best Answer - View smee82's answer

SanDiegoRedneck

Well Known
Member
Messages
832
Reaction score
705
noahhutch01 said:
A little over a week ago I purchased a fish tank and immediately began cycling the water. A few days ago I put in a few live plants. Today I am noticing a small white fuzz growing on one of the roots. I have attached a photo. What is it?? Is it safe or will it become a problem? Also, I’ve noticed that there’s a few snails crawling around. Are they going to become a problem? I’ve added a photo of them, too. My plan is to get fish whenever the water parameters indicate the tank is ready, but is there anything else I need to do to make sure this tank is safe for my plants and fish?
No the snails are fine they will help clean up. Picture is not good but I'm guessing snail eggs
 

smee82

Moderator
Moderator
Member
Messages
6,161
Reaction score
2,844
Location
Tianjin china
Experience
More than 10 years
SanDiegoRedneck said:
No the snails are fine they will help clean up. Picture is not good but I'm guessing snail eggs
Its not snail eggs it looks like a mold or fungus, how are you cycling your tank. If your using food thats probably your cause. The snails are bladder or pond snails and some peopke think theyre pests but they dont bother me.
 
  • Thread starter
  • Thread Starter
  • #4
OP
noahhutch01

noahhutch01

New Member
Member
Messages
13
Reaction score
3
Experience
3 years
smee82 said:
Its not snail eggs it looks like a mold or fungus, how are you cycling your tank. If your using food thats probably your cause.
I’m not using food, I’m just letting the filter run and waiting until the parameters say it’s okay to add fish. I did add in some aquatic plant fertilizer. What do I do about it? I’ve never had live plants before.
 

New Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
191
Guests online
3,304
Total visitors
3,495

Aquarium Photo Contests

Aquarium Calculator

Top Bottom