White Algae?

  1. Gollum127

    Gollum127 New Member Member

    *** UPDATE *** This stuff is now growing like a fuzzy/slime? on my driftwood... Any information would be greatly appreciated!

    So I just started a 75 gallon tank this past Saturday and by Sunday morning it was completely covered in this white stuff. All that is in the tank is some gravel, 1 fake plant, a large piece of driftwood (with some snails) from my planted/established 55 gallon, a sponge filter and HOB filter (rated for 75 gallons) with built-in UV sterilizer. I used water from the hose (as I always) do and treated accordingly with dechlorinator. Its now Tuesday and it doesnt seem to be growing so much other than on the sponge filter. I've never experienced this with any of my other/past tanks. Does anyone have any idea what this is and how do I get rid of it?!
     

    Attached Files:

  2. Coradee

    Coradee Moderator Moderator Member

    It's a fungus, quite common on new wood & harmless, should eventually go away by itself. If you don't like how it looks you can scrub it off but it may keep coming back for a while
     
  3. OP
    OP
    Gollum127

    Gollum127 New Member Member

    Thank you for your response. The weird part is that the wood is not new, it was in my planted 55 for the past year before I transferred it to the 75. I literally took it from one tank to the other and then overnight BOOM it was everywhere... The stuff is no longer growing on the driftwood, but its still all over the gravel, filters and even my snails.