Question What Just Happened?

Madison Lawson

Active Member
Member
Messages
80
Reaction score
19
Location
Centerton, AR
Experience
3 years
I just did a water change and added a little aquarium salt and treated the water for my Bettas fungal infection. I put him back in tank and just started wigging our. Swimming very erratically, going upside down, and then keeling over. I have had him for a year and he was fed over two years old. I followed the salt dosage on the apI aquarium salt package, and the water was about 80 degrees. I am so confused.

EDIT: I added too much salt. I didn’t measure the tank correctly. I feel horrible.
 

Fanatic

Fishlore VIP
Member
Messages
9,162
Reaction score
6,170
Location
Texas
Experience
3 years
Did you take the betta out during the water change? Did you make sure to acclimate him back to the tank before putting him into the water?
 
  • Thread starter
  • Thread Starter
  • #3
OP
Madison Lawson

Madison Lawson

Active Member
Member
Messages
80
Reaction score
19
Location
Centerton, AR
Experience
3 years
Fanatic said:
Did you take the betta out during the water change? Did you make sure to acclimate him back to the tank before putting him into the water?
Yes I did. I actually just edited that I added to much salt like an idiot. I feel absolutely awful.
 

Fanatic

Fishlore VIP
Member
Messages
9,162
Reaction score
6,170
Location
Texas
Experience
3 years
Madison Lawson said:
Yes I did. I actually just edited that I added to much salt like an idiot. I feel absolutely awful.
I would do a water change to remove the excess salt.
 

New Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
220
Guests online
5,300
Total visitors
5,520

Aquarium Photo Contests

Aquarium Calculator

Top Bottom