What is wrong with my plants??

Davidh9054

What am I doing wrong with this 10 gallon tank? All the plants in this tank look like this below. From swords to Anubias, I did the same thing as my other tank and my other tank looks great. I dot he same routine when I do my water changes and I still can’t get the plants to grow or thrive. There is also quite a bit of green algae that grows on the front of the glass and the rocks and wood. I really don’t understand I don’t have any of these issues with my other 20 gallon. In this 10 gallon I have a marine land strip led and seems like there’s more than enough light and I dose with flourish.


9488CA1B-9D26-4A99-9C68-FC0D5C45C3AA.jpeg

E6022D6B-EE19-43E2-8133-46DD98310AD1.jpeg

855CE336-D1A1-48E8-90AB-4D722331C10B.jpeg
 

Blacksheep1

It looks like algae growth. How long are your lights on for ?
 

Davidh9054

It looks like algae growth. How long are your lights on for ?
About 8-10 hrs. There is also quite a bit of yellowing. And my 20 gallon I keep my lights on even longer and the plants are doing great I see a new leaf from my Anubias plants every week to 2 weeks. On this 10 gallon I don’t see much new growth at all they’ve looks the same for months. By this time they should’ve at least grown a few new leaves.
 

Blacksheep1

Different lights will have different spectrums ( more red less blue etc ) and different lumens which affects growth. I see snails munching on the leaves which is good. It could be an iron / potassium deficiency , do you dose any ferts or use root tabs ?
 

Davidh9054

Different lights will have different spectrums ( more red less blue etc ) and different lumens which affects growth. I see snails munching on the leaves which is good. It could be an iron / potassium deficiency , do you dose any ferts or use root tabs ?
I use 1 marine land led strip in the 10 gallon. In the 20 gallon I use a FluvalSmart aqua sky together with a marine land led strip. I dose seachem flourish and there are seachem root tabs in the gravel. I was thinking of just trying to add more plants to see. How would I test to see if it is an iron or potassium deficiency?

This a picture of the 20 gallon. I use the same exact ferts in this tank as the 10 gallon.

9320E40C-BB66-4EB2-A489-A75FA0D8EE70.jpeg
 

Blacksheep1

I think there’s a test for potassium but honestly I’m not sure how you’d test. I’d guess using a different feet / tab with higher doses and see if it makes a difference.

I have the same issue with my swords if I’m honest and i use root tabs and dose ferts. I changed my light recently and it’s made a huge difference in the new growth. I know if I don’t add new root tabs every month they get holey real quick. My smaller tank with a cheap led light and very small bio load grows amazingly well so it’s a mystery to me too :D
The main thing I can think of is inert sand vs flora base pro. I’m constantly trimming the small tank they grow so fast
 

Davidh9054

I think there’s a test for potassium but honestly I’m not sure how you’d test. I’d guess using a different feet / tab with higher doses and see if it makes a difference.

I have the same issue with my swords if I’m honest and i use root tabs and dose ferts. I changed my light recently and it’s made a huge difference in the new growth. I know if I don’t add new root tabs every month they get holey real quick. My smaller tank with a cheap led light and very small bio load grows amazingly well so it’s a mystery to me too :D
The main thing I can think of is inert sand vs flora base pro. I’m constantly trimming the small tank they grow so fast
It might be I was thinking of just taking down the whole tank and redoing it. It’s been getting frustrating and just adding a ton more plants. And instead of using gravel using some type of aqua soil. It’s been frustrating and I was thinking of somehow lowering the intensity of the lights because it does seem kind of bright and I don’t have anywhere the amount of plants I have in my 20 gallon. I just wasn’t sure how. I was thinking of maybe wrapping aluminum foil on parts of the led strip but the light is submerged so I wasn’t sure if that would be ok.
 

Blacksheep1

If you search on here I’m sure I read a thread where someone covered every say 3rd or 4th led somehow . The soils do make a difference so it’s worth it if you have the patience to do it all over again
 

Davidh9054

If you search on here I’m sure I read a thread where someone covered every say 3rd or 4th led somehow . The soils do make a difference so it’s worth it if you have the patience to do it all over again
Patience I have to do it I love setting up tanks but I just don’t have much time for it now it would have to wait for a while. I will look up to see if I can cover the light with aluminum foil as tape won’t work since it is submerged.
 

Blacksheep1

Best of luck to you ! Don’t forget to post pictures when you get round to it ;)
 

Davidh9054

Best of luck to you ! Don’t forget to post pictures when you get round to it ;)
Thanks will do!!
 

Similar Aquarium Threads

Replies
2
Views
269
elisa001
  • Question
Replies
2
Views
246
Static823
Replies
5
Views
532
Allen121
  • Question
Replies
2
Views
230
trinity28
Replies
5
Views
202
Chiasmodon

New Plant Threads

Latest Aquarium Threads

Top Bottom