Help Vallisneria completely melting once brought for new tank?

Byron26

New Member
Member
Messages
9
Reaction score
1
Hi,

I brought some corkscrew Vals and afternoon 3 days they have completely melted...

I was wondering if I’m doing anything wrong?I have other plants like crypts etc which are fine so don’t understand why they melted this quickly as they are supposed to be easy plants?

thanks to anyone who helps!
 

Attachments

jake37

Well Known
Member
Messages
2,976
Reaction score
1,899
Experience
Just started
Give them a week and see if they regrow. A lot of plants suffer during shipping (either to you or the shop) and I've had val melt before but still manage to grow strong and healthy. Beyond that it is hard to say much - there is always a chance you put something in your tank they dislike such as salt or excel it is also they were abused at the place where they were purchased. When buying plants i will frequently ask the shop how long they had them - the longer the better because it gives an indication of the plants true condition.
 
  • Thread starter
  • Thread Starter
  • #3
OP
B

Byron26

New Member
Member
Messages
9
Reaction score
1
jake37 said:
Give them a week and see if they regrow. A lot of plants suffer during shipping (either to you or the shop) and I've had val melt before but still manage to grow strong and healthy. Beyond that it is hard to say much - there is always a chance you put something in your tank they dislike such as salt or excel it is also they were abused at the place where they were purchased. When buying plants i will frequently ask the shop how long they had them - the longer the better because it gives an indication of the plants true condition.
Cheers I’ll remove the dead leaves and keep the stems in there to see if they get better
 

New Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
216
Guests online
3,841
Total visitors
4,057

Aquarium Photo Contests

Aquarium Calculator

Top Bottom