Top Fin Silenstream 20 Not Working?

Discussion in 'Freshwater Beginners' started by AnastasiaRoseM, Jul 19, 2017.

  1. AnastasiaRoseM

    AnastasiaRoseMNew MemberMember

    Hey, everyone. I am in the process of setting up my second tank, which is a 10 gallon. I just bought the filter, tried to set it up today, and I can't seem to get it to work! I've tried taking apart the intake tube and putting it back. I filled up the reservoir before plugging it in. I got it to work for a few minutes but the flow rate was very low, just barely a trickle. Any suggestions? I know some people really don't like Top Fin, but that was an affordable option at the time. I might just go ahead and return it to get a different filter... If I do, any affordable suggestions?

    Thanks so much.
     
  2. Fish-whisperValued MemberMember

    Did you try adjusting the flow control knob ? water will trickle if closed. I have 6 of those filters and IMO they are a bargain. For around $5 you can mod them and they become super HOB filters.
     
  3. tocandesu

    tocandesuWell Known MemberMember

    I'm not sure how the updated Top Fin filters work, but can you disassemble it until you reach the impeller?

    This is what an impeller should kind of look like
    25870.ashx?w=300&h=300&bc=white.jpg

    Plug it in for a second and see if it spins. Then reassembly piece by piece and check if that still spins.

    If nothing seems to be blocking the impeller's movement and nothing is in the way of the intake tubes, try running the filter without the included media. If it's still a trickle, I would exchange the filter.
     
  4. ChichLove79

    ChichLove79Valued MemberMember

    If it's brand new, just take it back. If you have the box and receipt they should do an exchange.
     
  5. OP
    OP
    AnastasiaRoseM

    AnastasiaRoseMNew MemberMember

    I'll try just checking the propeller. I have adjusted the flow rate numerous times and it seemed to make little to no difference. I also unplugged it and dumped it out, disassembled and reassembled, filled up the reservoir again, and it would fill up enough to get to the top but not to actually spill over and circulate....
     
  6. Fish-whisperValued MemberMember

    When you start the filter you need to keep pouring water in the reservoir and soon the pickup tube will prime and flow. If it doesn't take the filter back.
     
  7. OP
    OP
    AnastasiaRoseM

    AnastasiaRoseMNew MemberMember

    Even after checking the impeller and continuing to pour water in the reservoir it failed to prime and flow, so it looks like I'll be returning the filter and getting a different brand...
     
  8. Tragic13

    Tragic13Valued MemberMember

    I personally like the Marineland Bio-Wheels if I have to have a HOB.
     




  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice