This is a real bummer

  1. Hippiechick

    Hippiechick Initiate Member

    Messages:
    21
    Ratings:
    +0
    I just had bought some new angels and I'll be darned if I can understand what happened here but 2 of the angels I've had for a long time just suddenly died. They weren't sick and had eaten well the night before and I don't see any damage on either of their bodies. :'(

    The worst part of it is that one of the ones that died was one that I had raised from an egg. :'( :mad:
     

  2. Susie

    Susie Initiate Member

    Messages:
    34
    Ratings:
    +0
    I'm so sorry for your loss.
     

  3. OP
    OP
    Hippiechick

    Hippiechick Initiate Member

    Messages:
    21
    Ratings:
    +0
    Thanks Susie. I just hate it when I loose fish and even more so when I don't have a reason as to why.
     
  4. Mike

    Mike Fishlore Admin Moderator Member

    Messages:
    7,961
    Location:
    USA
    Ratings:
    +676
    Sorry you lost your angelfish. Angelfish often carry intestinal parasites and I'm wondering if the store bought Angelfish had them. Did the angelfish that died not eat for the past few days?
     
  5. OP
    OP
    Hippiechick

    Hippiechick Initiate Member

    Messages:
    21
    Ratings:
    +0
    No, they were eating. Since then I've lost my other baby I've raised from an egg and the new Koi died just today. I checked the parameters and I have trace amounts of ammonia and nitrites. So I did a 25% water change this morning. (This was prior to the Koi dieing) I'll do another 25% water change in the morning and retest tomorrow evening.
    Any other ideas?
     
  6. Craig

    Craig Well Known Member Member

    Messages:
    677
    Location:
    Dunmurry, Northern Ireland (UK)
    Ratings:
    +0
    Im new 2 this and i havent had any losses yet but when it comes i know it will suck im sorry 4 ur loss also
     
  7. fletch

    fletch Member Member

    Messages:
    293
    Ratings:
    +1
    other than parasites, did you have a powercut?
     
  8. FishFan

    FishFan Member Member

    Messages:
    182
    Ratings:
    +0
    I, too, am so sorry for your loss. I am currently going through something similar. My fish eat and die. It seems the newer ones are the ones dying, except for a few I've had longer. I've treated my tank numerous times for different things, but nothing seems to work. I do partial water changes weekly and check my levels (parameters) at least twice a week-and they're fine. So, I don't really know what it is. It also seems that in my area, all of the pet/fish stores get their shipments in on Thursday's. Could it be the quality from the distributers? I am at a loss, as well. No ideas here, sorry.
     
  9. fletch

    fletch Member Member

    Messages:
    293
    Ratings:
    +1
    try putting some commercial bacteria in. if nothing else it will be realy beneficial for your existing colony.
     
  10. FishFan

    FishFan Member Member

    Messages:
    182
    Ratings:
    +0
    I already do. Whenever I do a partial water chage (weekly) I replace all the liquid additives and salt. Now that I don't have any mollies left, should I not put the salt in? Or is it still OK to add? I think I'm more confused now than when I began! :-\
     

  11. fletch

    fletch Member Member

    Messages:
    293
    Ratings:
    +1
    how do you wash your sponge? if you wash it under tap water it kills your colony. you need to get some tank water in a bowl and gently rub the spong together, keeping the bacteria in it
     
  12. FishFan

    FishFan Member Member

    Messages:
    182
    Ratings:
    +0
    I don't use a sponge. I use a power filter and when I do rinse out the white/permanent filter, I use tap water. Good thinking. Next time, I'll rinse it as you suggested. Thanks!
     

Share This Page