Tetra Ht10 50 Watt

Ariyan

Valued Member
Messages
103
Reaction score
10
Points
28
I just got a tetra ht10 water heater and i put it in my 5 gallon tank to heat up the water and it keeps turning on and off it stays on for like a minute and then it turns off is this normal?
 

Repolie

Well Known Member
Messages
3,569
Reaction score
2,189
Points
298
Experience
4 years
I got what I thought was a Tetra HT10 Heater from Walmart and it would light on then never turn on again unless I plug it back in. Then it repeats again, I look at the packaging and noticed it was different from my other Tetra HT10 Heater that I got from a reputable petstore and works fine. I returned that heater to Walmart and repurchased the same heater from the petstore and it also works fine. Where did you get yours from?

Walmart packaging:

Reputable packaging: http://feeds2.yourstorewizards.com/1298/images/250x1000/submrsblhtr50.jpg
 
  • Thread starter
  • Thread Starter
  • #7

Ariyan

Valued Member
Messages
103
Reaction score
10
Points
28
I got what I thought was a Tetra HT10 Heater from Walmart and it would light on then never turn on again unless I plug it back in. Then it repeats again, I look at the packaging and noticed it was different from my other Tetra HT10 Heater that I got from a reputable petstore and works fine. I returned that heater to Walmart and repurchased the same heater from the petstore and it also works fine. Where did you get yours from?

Walmart packaging:

Reputable packaging: http://feeds2.yourstorewizards.com/1298/images/250x1000/submrsblhtr50.jpg
Walmart
 

Repolie

Well Known Member
Messages
3,569
Reaction score
2,189
Points
298
Experience
4 years
Yeah I don't trust the ones from Walmart. The ones they sell don't work and seem to be different from petstore one. Go return it and purchase a different heater from a reputable petstore.
 
  • Thread starter
  • Thread Starter
  • #9

Ariyan

Valued Member
Messages
103
Reaction score
10
Points
28
Yeah I don't trust the ones from Walmart. The ones they sell don't work and seem to be different from petstore one. Go return it and purchase a different heater from a reputable petstore.
I think its working its at 76 degrees is that why the light might be off?
 

THRESHER

Well Known Member
Messages
811
Reaction score
427
Points
53
Experience
5 to 10 years
I got a Tetra HT10 heater that came with some used accessories I bought cheap. It works great in my 20G. Keeps temp constant @ 79 for my Dragon Goby. A little red dot comes on, stays on for a while, then shuts off as normal. Sadly it didn't come with any packaging as it was used.
 

Repolie

Well Known Member
Messages
3,569
Reaction score
2,189
Points
298
Experience
4 years
I think its working its at 76 degrees is that why the light might be off?
Yeah that's what I don't know. A legitimate Tetra HT10 Heater will always have the light indicating that it's on and red will be when it's heating up and green is when it reaches the proper temperature.

Edit: The Tetra company also doesn't even have that heater listed on their website.
 

Carolyn Underwood

Valued Member
Messages
191
Reaction score
90
Points
73
Experience
1 year
This thread makes me happy I bought my little heater at Animal House Pet Store. I thought it was kind of expensive, but considering all the time and trouble I could have had, it was worth the $20 I paid for it.
 
Toggle Sidebar

Aquarium Calculator

Follow FishLore!





Top Bottom