Takes weeks to get visible algae

Grace4514

Active Member
Member
Messages
269
Reaction score
92
So this might sound dumb, but I barely get any algae at all in my 55 gallon tank. I can go weeks without cleaned the glass and then I'll only get a few specks. Is this a bad sign? I have one nerite snail now, but even before I had him it was the same. I know everyone hates algae and it's a pain to keep away for most, but I'm wondering why I dont really have any at all?
 

StarGirl15

Fishlore VIP
Member
Messages
4,366
Reaction score
5,356
Location
Michigan
Experience
More than 10 years
Wow that is strange. lol I really dont have a answer for that. I dont scrape my glass much either. Just my plants have specks of algae. I guess if you want some leave your light on longer?
 

TWiG87

Well Known
Member
Messages
2,354
Reaction score
2,229
Location
NJ
Experience
5 to 10 years
I’m assuming you have live plants? If you do, you u have achieved a very good balance of light, fertilizer and bioload
 
  • Thread starter
  • Thread Starter
  • #7
OP
Grace4514

Grace4514

Active Member
Member
Messages
269
Reaction score
92
I leave my lights on 8-10 hours a day sometimes it's like 12 if I'm not home in time
 

StarGirl15

Fishlore VIP
Member
Messages
4,366
Reaction score
5,356
Location
Michigan
Experience
More than 10 years
Huh that is weird. I bet most keepers would die for that....lol I would LOVE to be able to have my light on that long.
 

Donovan Jones

Well Known
Member
Messages
670
Reaction score
343
Location
Pennsylvania
Experience
5 to 10 years
Could be too low of light for it to be a problem? Or maybe the water chemistry isn't conducive to algae?
 

New Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
197
Guests online
2,790
Total visitors
2,987

Aquarium Photo Contests

Aquarium Calculator

Top Bottom