T8 strip light acting weird

Discussion in 'Lighting' started by oOBlueOo, Aug 8, 2015.

  1. oOBlueOoWell Known MemberMember

    I have a T8 strip light on my 10g that I got from petco about a year ago.

    Last night when I flipped the switch off, it was dark for about 15 seconds, then all of a sudden it flickered. I quickly unplugged it and figured there was a short in the wiring or something.

    I just moved and I bet it got bumped. But it was kinda creepy standing there in the complete darkness with a light acting all spooky and whatnot.....

    So is this something I should worry about? Is it time to toss the fixture and get a new one?
     
  2. Sarcasm IncludedWell Known MemberMember

    Usually it is just a short in the switch, which can be replaced easily if you want to save the expense.
     
  3. DolfanFishlore VIPMember

    I would bet that either the bulb was a bit loose and the pins were not seated correctly, or more likely you may need a new ballast.
     
  4. oOBlueOoWell Known MemberMember

    Would it be ok to run it yet or should I put my spare on instead?
     
  5. Sarcasm IncludedWell Known MemberMember

    If he is turning it off and it starts blinking then it would have to be at the switch, since even a bad ballast won't blink without power. If it blinks after the power is turned on then it can be the ballast or bad connection.
    Yes you can still use it but it kills the bulb lifespan.
     
  6. DolfanFishlore VIPMember

    You are right, I misread the original post and thought the flickering was happening when the light was on. If it's happening when the light is switched off, then Sarcasm is right, it's probably a bad switch.
     
  7. Sarcasm IncludedWell Known MemberMember

    Well since it is usually you correcting me, I'm going to celebrate, lol
    :;toast:
     
  8. oOBlueOoWell Known MemberMember

    So then ill probably want to run the spare one.

    I have a lot of plants in this tank. Java fern, anubias, vals, compacts, red root floaters, hornwort, pennywort, japonica, and subwassertang. Plus more I forgot. They're all low light as far as I'm aware.

    My spare light is a Current freshwater led. Not the plus, though. I believe its 6500k. So it should be just fine, right?
     
Loading...