Sunsun Submersible Heater

Lcarr727

I bought a SunSun 100 watt submersible heater for my tank. I put it in the tank yesterday afternoon and set it to 78f. I checked the tank temp this morning and it's only at 75f. I noticed the heater will only turn on for about 5 minutes after I adjust the temp then not turn on again. The directions were not good as it's translated from Chinese and don't really give you any information of how to use it or where to position it. I currently have it next to my filter intake on a slight angle ( otherwise it wouldn't be fully under water. I can see it's working when it's on for those 5 minutes..Has anyone used this before, have any tips or info about it?
 

California L33

The easy way to test it is to put it in a big bowl of cool water- like 50 degrees, and see if it warms it all the way. If it does, drain some of he warm water and slowly add 50 degree water again and see if that gets it to turn on.

Honestly, I think the thermostat is probably just slightly misadjusted, and it may require a couple of degrees to get it to turn back on.
 

Lcarr727

I tried turning it up to 82 when my tank is at 75 and it did the same thing. My tank is normally 75 without a heater.
 

tocandesu

I tried turning it up to 82 when my tank is at 75 and it did the same thing. My tank is normally 75 without a heater.
Does it turn on at all when turned up to the max?

Either the thermometer is off or the heater is malfunctioning.
 

Similar Aquarium Threads

  • Question
  • ghostdawg
  • Heater
Replies
7
Views
422
ghostdawg
  • Question
  • bumblinBee
  • Heater
Replies
9
Views
304
bumblinBee
Replies
2
Views
5K
sassymomma
  • Silister Trench
  • Heater
Replies
1
Views
5K
Coradee
Replies
6
Views
515
SamLynn

New Aquarium Heater Threads

Latest Aquarium Threads

Top Bottom