SunSun HW-404B 5-Stage External Canister Filter NO SUCTION

nic63impss

New Member
Messages
1
Reaction score
0
Points
26
Experience
Just started
I have a SunSun HW-404B 5-Stage External Canister Filter for about 1 year. It has worked fine until about a week ago it stopped sucking water. I can hear the pump still running but it is not sucking water. I have taken it apart and cleaned it, filled the water and it overflowed when i put it back together, I plugged back in, pump is running but still no suction. I pumped for about 15 minutes and primer sounds like it is worked but no suction. I filled green tube with water and turned back on, the water in the green tube emptied into the filter but still no suction. I disconnected the green tube from the from the black tube and i can not feel any suction. What could the problem be? is there a issue in the pump possibly?

The pump is being used on a 40 gallon fish tank for 2 red ear slider turtles. The tank is about 1/3 full of water. Please let me know if there is any information you may need.
 

Bluestreakfl

Well Known Member
Messages
2,076
Reaction score
74
Points
93
Experience
1 year
Is this one with the external pump, where the pump is a separate piece from the cannister? If so, try just sumberging the pump and turning it on to see if water is being pushed through it. If so, there may be a blockage elsewhere. Also, dumb question, but does yours have valve shutoffs where the hoses connect to the canister? I know mine does, and possibly the output valve is shut off?
 

Erbarry

Valued Member
Messages
77
Reaction score
0
Points
41
Experience
Just started
Have you pulled out the impeller? When you first fill it up and plug it in does it spray out the spray bar?
 
Toggle Sidebar

Aquarium Calculator

Follow FishLore!





Top Bottom