Sudden Algae Bloom 5 Gallon Tank

  1. kimoore Member Member

    Hello, i use this tank for fry. I have had it up and running for a while. Currently it houses RCS, MTS and 2 pygmy corys. I left for an over night trip,(the light was OFF the entire time,) and came back to everything covered in a clearish-whitish slime thing. What is it? How do get rid of it? Or, do I just let the RCS and MTS take care it? (Since the bloom, everything has gone into mating overdrive... EVERY single female RCS i see is berried and there are loads of itty-bitty baby snails.)
     
  2. catsma_97504 Fishlore Legend Member

    Not sure what type of algae that is....or even if it is algae.

    What are your current water parameters? Have you done any recent tank maintenance add or removed any items? Decor, driftwood, filter maintenance? Do you have live plants in this tank?

    Sorry for all the questions. Just trying to figure out what may be going on in your tank.
     

  3. kimoore Member Member

    I did replace the filter cartridge. Water stats; amm 0, nitrite 0, nitrate >10, I havent added anything to the tank. And what I feed has remained the same. (just some sinking waffers and the occasional veg) I do have live plants, some grass and java moss. Temp remains pretty steady at 74 degrees F. I gravel vac around every 9 days. With MTS, RCS and corys, things stay pretty clean.
     
  4. pirahnah3 Fishlore VIP Member

    Dunno, could it be a bunch of egg shells or egg sacks from the snails hatching?

    If the critters are not being bothered or showing signs of stress I would see what happens in the next day or two.
     

  5. kimoore Member Member

    I thought MTS give birth to live young? I just remembered, i did clean off the media holder thing... could that have done it?
     
  6. can haz catfishies? Member Member

    I had something similar when I set up my second tank but it appeared in between a bit of bog wood and the tank glass, never found out what it was although after removing the wood cleaning it and the tank it never came back so try giving the area a good clean if you can and just keep an eye on it coming back
     
  7. Butterfly Moderator Moderator Member

    MTS do give live birth :)
    At this point a picture would be most helpful.
    Carol
     

  8. kimoore Member Member

    well, i added an extra air stone.... witin 24 hours it was gone and the tank is sparkling, it actually twinkles!