silk plant with spots

lisab53

I have had my 20 gallon long tank up and running now for a month. The goldfish have been in for almost three weeks now. They seem to be doing really well and the tank water looks great. I do notice though that the silk plants are getting brown spots on them. I assume maybe this is algae? I just wondered if when I do the weekly water change and gravel cleaning, should I be taking the plants out to clean also? If so, how is best and safe to clean them? I am surprised at how much I am enjoying my aquarium and am thinking about getting another.

Thanks for any help,
Lisa B
 

tan.b

i'd guess so, but i'm no expert. my filter has brown splodges on it, but they don't rub off, so I just leave it. quite useful on a filter as it camouflages it!! can't help you with your plants i'm afraid. over feeding your fish can cause algae I believe? they should have enough food to last about 3 mins. any more and it should be removed. too much light can cause algae too. hope someone helps you soon.
 

shollia

Sounds like it's probably brown algae. I'm getting that in my tank as well.. mainly just on my anubias plant. Every few days when I'm doing a water change, I'll stick my hand in and rub the algae off the leaves. Guess you could do that with your silk plants as well. Just wash them off in some dechlorinated water.
 

Similar Aquarium Threads

Replies
6
Views
135
Msdp11009
Replies
1
Views
76
cichlidL
  • Question
  • TeeJay89
  • Snails
Replies
6
Views
142
mattgirl
Replies
3
Views
138
MasterPython
  • Question
Replies
1
Views
176
FishPlanet

Random Great Thread

New Plant Threads

Latest Aquarium Threads

Top Bottom