Rena Cannister Filter issue

  • Thread starter

WMThunder36

New Member
Messages
41
Reaction score
0
Points
33
Hi, my rena xp-3 (xp-l) filter will not stay full. when i manually fill the cannister and plug in filter it works fine but after a couple of hours the water in the cannister drains and you can clearly see a waterline and that its not full like i left it. Any ideas on why this is happening? PS. already tried tightening hose clamps and i got metal ones to replace the plastic ones it came with.
 
  • Moderator

Coradee

Moderator
Messages
17,671
Reaction score
5,182
Points
808
Experience
More than 10 years
Bumping this up for you
 

leftswerve

Well Known Member
Messages
1,474
Reaction score
415
Points
128
Experience
More than 10 years
If you can't find any leaks, then look at the intake and see if it needs cleaning. If it is clogged, the unit can slowly suck air from any very small seal.
 

hacksaw15

Valued Member
Messages
97
Reaction score
5
Points
113
Experience
5 to 10 years
If their is no leak then just turn the flow down. This is a on going issue with Rena's. I've using Rena canisters for 7 years and this seems to be the only issue I ever had with them. I run them at around 3/4 open. This was a problem with first starting them and after cleaning. About a week or two later I was able to open them all the way. Lately I just leave at 3/4 open.
 

PiZauL

New Member
Messages
11
Reaction score
1
Points
28
Experience
2 years
When I had my rena I had the same problem, apparently a common issue. I did this "fix" to mine after every service period until I got rid of it. Was pretty annoying and I overall had a bad experience with this canister.
 
Toggle Sidebar

New Threads

Similar Threads

Aquarium Calculator

Aquarium Photo Contests

Follow FishLore!

FishLore on Social Media





Top Bottom