Pale white algae like thing on fish? what can it be?

mansapatil007
Member
I have a 10 gallon fish tank with gravel and driftwood with airstone and water filter. Also have few Anacharis plants. I added driftwood week ago put them in hot water before adding. I noticed one of my fish is getting pale white algae like spots on head (only left side Please see pictures), and acting little calm then before. I am worried if that some kind of disease or something. can you please help to recover my fish.

Thanks
 
JenC
Member
Welcome to Fishlore.

I don't see any pictures. Could you try attaching or linking to them again?

If you could tell us a bit about your tank it would be helpful. What fish are in the tank, how long it's been running, your water parameters if you know them (ammonia, nitrite, nitrate, temp), etc.
 
JamieLu
Member
Ok not trying to b rude here but a 10gallon tank is too small for even 1 goldfish and i see at least 3 in there? Im willing to bet the fish is sick because your tank is way overstocked and your water params are off. What is your ammonia, nitrite and nitrate readings? Do u have a test kit?
 
  • Thread Starter
mansapatil007
Member
Thanks for Attention JenC,
Tank Details: 10 Gallon, only 2 month old setup, Goldfishes only, Temp average 72F, due to new setup i mostly change 50% water a week(sometimes twice a week). I use API Ammonia strips and they always give beteen 3.0 to 6.0 reading (even after water change, not sure if they are correct). then I put Ammonia clear tablet 2 days back just to be safe side.

Thanks Again.
 
  • Thread Starter
mansapatil007
Member
JamieLu said:
Ok not trying to b rude here but a 10gallon tank is too small for even 1 goldfish and i see at least 3 in there? Im willing to bet the fish is sick because your tank is way overstocked and your water params are off. What is your ammonia, nitrite and nitrate readings? Do u have a test kit?
Thanks JamieLu, This is what Petco guy suggested, he said 5 will be okay since they are babies.
 
JamieLu
Member
Ok well i think that ur fish has ammonia burns. Can u test ur tap water and see what ur ammonia level is out of the tap? 3-6 in the tank is super high. U should try to get an api liquid test kit so u can test all ur parameters so u can see if ur tank is cycling properly and its just good to know ph and other things. Test strips arent very accurate. i had them before and always got different readings than what my liquid kit gave me. Do u know about the nitrogen cycle? If not please read up on it. Also, what filter do u have? Please dont change out the filter cartridges even though it says to. U need the good bacteria on those to process the ammonia. Also i would get a bottle pf prime water dechlorinator ASAP. It also neutralizes ammonia and nitrites so ur fish will b more protected. Id get that first and foremost. NEVER trust the pet store employees cuz they just want to sell u stuff thats it. Even if ur fish are babies they require much bigger tanks. U should always do ur own research online. Its going to be very hard to keep the ammonia down in a small tank with such messy fish. I would feed VERY little food and change out like 50%-70% of the water right now to get ur ammonia down. U want it below 1ppm if possible. So if u change 50% now that wont drop it under 1ppm so ull need to do another water change later in the day or the following day. Then keep doing atleast 50%daily until ur cycled. Water changes and prime is all u need to deal with the ammonia. I would not recommend anything that gets rid of ammonia (like ammonia clear tablets) cuz then ur good bacteria cant grow. I hope I'm making sense to u. We have all been in ur position in regards to not knowing about the nitrogen cycle or putting the wrong fish in the wrong tanks. Do u have a way to take the goldfish back? Maybe get some guppies instead, or something more suitable for a 10 gal tank?
 
Broggy
Member
im no fish disease expert but it looks like ick
 
JamieLu
Member
Actually it doesnt look like ich at all...atleast from the pics it looks red, inflammed and like the slime coat is irritated. Ich looks like salt all over the body usually starting on the fins first
 
  • Thread Starter
mansapatil007
Member
JamieLu said:
Ok well i think that ur fish has ammonia burns. Can u test ur tap water and see what ur ammonia level is out of the tap? 3-6 in the tank is super high. U should try to get an api liquid test kit so u can test all ur parameters so u can see if ur tank is cycling properly and its just good to know ph and other things. Test strips arent very accurate. i had them before and always got different readings than what my liquid kit gave me. Do u know about the nitrogen cycle? If not please read up on it. Also, what filter do u have? Please dont change out the filter cartridges even though it says to. U need the good bacteria on those to process the ammonia. Also i would get a bottle pf prime water dechlorinator ASAP. It also neutralizes ammonia and nitrites so ur fish will b more protected. Id get that first and foremost. NEVER trust the pet store employees cuz they just want to sell u stuff thats it. Even if ur fish are babies they require much bigger tanks. U should always do ur own research online. Its going to be very hard to keep the ammonia down in a small tank with such messy fish. I would feed VERY little food and change out like 50%-70% of the water right now to get ur ammonia down. U want it below 1ppm if possible. So if u change 50% now that wont drop it under 1ppm so ull need to do another water change later in the day or the following day. Then keep doing atleast 50%daily until ur cycled. Water changes and prime is all u need to deal with the ammonia. I would not recommend anything that gets rid of ammonia (like ammonia clear tablets) cuz then ur good bacteria cant grow. I hope I'm making sense to u. We have all been in ur position in regards to not knowing about the nitrogen cycle or putting the wrong fish in the wrong tanks. Do u have a way to take the goldfish back? Maybe get some guppies instead, or something more suitable for a 10 gal tank?
Thanks JamieLu,
I thought same yesterday (That it might be Ammonia burn), and replaced 50% water and will do it again today. Strips are definitely not accurate, hence will order api liquid test kit (thanks for suggestion). I have bit knowledge of nitrogen cycle (from youtube and forums). I am using same "Prime Concentrated Conditioner for marine and fresh water", around half cap for 5 gallons of tape water. "I would feed VERY little food", recently i have started feeding them little more then before. I will definitely control that. I feed them twice a day. 10 am and 10 pm. I also removed Driftwood so that tank can hold little more water and give them more space. For returning fish, I will ask Store guys next time I visit.

Thanks a lot for your help.
 
JamieLu
Member
mansapatil007 said:
Thanks JamieLu,
I thought same yesterday (That it might be Ammonia burn), and replaced 50% water and will do it again today. Strips are definitely not accurate, hence will order api liquid test kit (thanks for suggestion). I have bit knowledge of nitrogen cycle (from youtube and forums). I am using same "Prime Concentrated Conditioner for marine and fresh water", around half cap for 5 gallons of tape water. "I would feed VERY little food", recently i have started feeding them little more then before. I will definitely control that. I feed them twice a day. 10 am and 10 pm. I also removed Driftwood so that tank can hold little more water and give them more space. For returning fish, I will ask Store guys next time I visit.

Thanks a lot for your help.
Nice! Sounds like ull b just fine and hopefully get it all sorted out. Good luck to u!
 
  • Thread Starter
mansapatil007
Member
JamieLu said:
Nice! Sounds like ull b just fine and hopefully get it all sorted out. Good luck to u!
Thanks once again.
 
  • Thread Starter
mansapatil007
Member
Update:
I removed driftwood and stones I added recently. Noticed improvement in their behavior (specially with one in pic). Also i purchased API freshwater test kit as JamieLu mentioned (thanks once again) and tests are fine (I guess it is , Please refer to pics for test results).
Thanks for help once again.
 

Random Great Thread

Latest threads

Top Bottom