Ok, Need Help Making A Eheim Ecco Pro Canister Filter Actually Work

Discussion in 'Filters and Filtration' started by Homeslice, Aug 14, 2019.

  1. Homeslice

    HomesliceWell Known MemberMember

    So I ordered an Eheim Ecco Pro canister filter. I thought it weird that I didn't really see them on U.S. Amazon or Ebay. Found some on UK ebay. No problem, I ordered one. Then I started thinking about it... sure enough they are like 220 volts, not 110 like we have in the U.S.

    No big deal. I order a 110/220 volt converter.

    At first I couldn't even get the thing to start. But then realized I had the "input" on the back of the power convert set to like 240 (like it came), but when I changed it to 110 I got the pump to at least turn on.

    But looking at this video:



    Right at the 10 minute mark, he basically says how to get it working - pull the handle down, wait 10 seconds, push it back up.

    But when I do this, when I push it back up, and I do see some water expelled from the hoses into the tank (and some on my carpet lol), and while I hear the motor running (very quietly, but its definately running), water never starts flowing, even after a long time.

    Pictures below.

    I am a 100% newb when it comes to canister filters, so I am about 99% sure it is user error!

    Thank you for any help!!!

    [​IMG] [​IMG] [​IMG]
     
    Last edited by a moderator: Aug 16, 2019
  2. aussieJJDude

    aussieJJDudeWell Known MemberMember

    Did you add some water to the canister prior to filling it up (and have it all ready to go on the aquarium, hose and all?)


    If it's already been filled up with water, what I find handy is a little unconventional, but it's something I had to do with a prior canister to get it to run (not the same unit as an eco pro) and now do it with my eco pros after I finish cleaning them out.


    I pick it up, and then just get the entire canister and tip it on its side. Usually by then, theres enough water in the impeller unit that it can start flowing and push out enough air that I begin to slowly straighten it back out until it's running in a position...


    Rocking it gently to help push out air also helps...
     
  3. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember

    Thank you aussieJJDude, will try that tonight!
     
  4. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember

    Well shoot aussieJJDude, I made sure it was filled with water, closed it, I hear the motor running, tilted it left, tilted it right, tilted it upside down, water is just not flowing. One of the tubes seemed a little cinched, fixed that, still nothing. Now its just next to me making that "trying to suck but failing" noise. Any other ideas? :)

    :(
     
  5. Islandvic

    IslandvicWell Known MemberMember

    Here is an idea......

    Turn off the Ecco and remove the strainer.

    Get one of your water pumps and place its discharge barb up into the Ecco's intake pipe and turn on the pump.

    This should fully prime the Ecco, blowing out any air that could be trapped.

    Put the strainer back on and plug the Ecco back in.

    Does it work now?
     
  6. johnbirg

    johnbirgValued MemberMember

    Suck on the return hose while it's running. Pretty cruddy way to get them going but that's Eheim for you. No priming mechanism and lots of cost.
     
  7. Cichlidude

    CichlidudeWell Known MemberMember

    If you have to do all this just to get a simple canister to run, it is defective. Send it back for a refund.
     
  8. DoubleDutch

    DoubleDutchFishlore LegendMember

    First get it syphoning (is it under waterlevel of your tank?). Last resort is to suck on the outlet to get the syphoning starting. Are the cranes/valves open?


    The filter doesn't suck, but only pumps water out.

    They are great filters btw. Two warnings : grease the rubberring now and then amd buy some spare axes, cause they need immwdiately replacement when broken.
     
  9. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember

    Thanks so much! I tried the pump below the water line on the floor, holding it at the water line, holding it above the water line, nothing made it work.

    Valves are definitely open.

    I will try sucking on the intake when I get home from work. If that does not work will try the other pump method IslandVic mentioned.

    Will follow up with you gents tonight! Thanks!

    P.S. any risk that that 110v to 220v converter could be the problem? It seems weird to me that it could just convert what I understand is less powerful electricity (110v) to more powerful electricity (220v), but I know nothing about the issue. The pump is definately turning on and trying to pump, I just wonder if it might be "underpowered" because it is not getting true 220v electricity or whatever.
     
  10. Marinus

    MarinusNew MemberMember

    Granted I haven't used the ecco pro but I do have an eheim classic 2213 canister filter and have never had to do that much with it to get it running. o_O Sounds like it might be a problem with the canister itself rather than user error, especially if everyone else's suggestions are not working. I have no idea if the difference in voltage would be part of the problem, sorry! But, if it were me, I would return it and either ask for a replacement or just get your money back and get a different eheim filter.

    I love my eheim and have had hardly any issues with it at all, runs like a champ and has been going for about 10 years strong now. I had to replace the shaft and bushings once but that was because I broke it while taking it apart to clean, totally my fault and not the pump. Mine starts up pretty easily, After cleaning I refill with water, have the quick release valves closed so the water remains in them and once everything is hooked back up I plug in, it starts, and I give it a couple taps/gentle shakes to get bubbles out. This has worked great for me.
     
  11. DoubleDutch

    DoubleDutchFishlore LegendMember

    Under water level and suck on the outlet hose so the syphoning will start. After having do that you dont have to a second time. You unplug it then, close the valves, unplug the adapters from the filterhead, clean the cannister, plug the adapters in, open the valves and the filter will automatically fill itself (if not a suck on the outlet will help), let it fill itself and if it is filled plug it in (there will be some air trapped so wiggle the cannister a few times)

    Don't know about the power, but if you hear the impellor work that shouldn't be the problem.

    Filling it for the first time is I think.
     
  12. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember

    Thank you Marinus and DoubleDutch! I will give it a try tonight. I sure hope its just an issue of getting water in there the first time - I ordered it off EBAY, U.K. edition so returning it might be a bit of a problem haha.


    Sorry DoubleDutch, I meant suck on outlet, not intake, I don't think sucking on the intake would work very well! :)
     
    Last edited by a moderator: Aug 16, 2019
  13. DoubleDutch

    DoubleDutchFishlore LegendMember

    Cleaned all my 3 Ecco's yesterday.
    Had to do this twice hahaha
     
  14. Michael.j.gomez

    Michael.j.gomezValued MemberMember

    Hello, don't own a eheim but to get my cascade 1000 to work after cleaning I fill canister w/treated water, button everything up & attach output valve open(goes to tank). I get a 5gal bucket, start siphon on input (water should have strong flow)then shut valve, attach to canister, plug in & open input valve. This works for me every time. Hope this helps you!!!!!
     
  15. Mongo75

    Mongo75Valued MemberMember

    Voltage shouldn't be a problem . Current (amps) and watts are the limiting factors. 220v uses less amperage (amps) to achieve the same same power (watts) as 110v. Your 100 watt transformer should be enough to handle the power requirements of that motor with plenty of room to spare.

    I looked up the Eheim 2236 and it draws about 8 watts. That would be 0.0364 amps at 220 v and 0.0727 amps at 110 v. At the full 100 watt rating of your transformer, at 110 volts you could pull 0.9091 amps. That's roughly 12 times more power that you're using now.

    Hope that helps your concern as to the power issue.
     
  16. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember


    Thank you Michael! Sounds very similar to what IslandVic suggested above! thanks!


    That is does Mongo, that it does! Thanks!
     
    Last edited by a moderator: Aug 16, 2019
  17. OP
    OP
    Homeslice

    HomesliceWell Known MemberMember

    OK guys, I think the darn thing is defective.

    I tried sucking on the output hose. No dice.

    I went straight to IslandVic's kill move - hook up a pump to the intake and RAM the water through it to make sure it is all water, no air. So I hooked up a trusty little Kedsum pump. And it caused water to flow through it all right. But I still hear that sound from the Ecco pump like it is somehow trying to pump mostly air. I turned the Kedsum pump off, and sure enough, the flow that was going gangbusters through the canister completely stops. And I still hear the Ecco pump making the same noise.

    Anything else I can try at this point or just write this one off?

    Thanks!
     
  18. Mongo75

    Mongo75Valued MemberMember

    Just thinking out loud and not knowing this unit...gut it. Remove all media an take out the impeller. See if the impeller is binding on anything or does it turn freely. There will be some resistance from the magnets in the motor and you may feel it "jump" when it hits the magnetic field as it turns, but it should not bind or grind or catch in its movement.

    Take the empty unit to the kitchen sink, or the bath tub and fill it up. Plug it in and see if the impeller turns and will empty it. Don't run it dry though. That will damage it. A few seconds won't hurt though.

    Just thinking about what I would try...
     
  19. DoubleDutch

    DoubleDutchFishlore LegendMember

    Does it fill with water after you sucked on the outlet? That process hasn't to do with power etc..... It should fill itself.
     
  20. Islandvic

    IslandvicWell Known MemberMember

    Ok, I've got 2 theories now....

    First, an internal seal or oring wasn't installed correctly at the factory, and air is entering the system.

    Here is a LINK I found of the parts diagram schematic of the Ecco.

    It looks like there are 2 orings inside the motorhead, where it connects to the intake and discharge valves.

    Can you remove the top panel to access these orings, and make sure they were installed correctly and not misaligned? Maybe put some silicone lube on them.

    Second, is it possible the fault lies with the voltage converter?

    From the pics, it looks like the converter can both set-up and step-down voltage.

    I know American electrics operate at 60hz AC. From what I recall, Europeans operate at 50hz AC.

    Maybe the converter is bumping up the voltage from our 110v, to the Euro Eheim's required 220-230v, but the converter is not changing the frequency to 50hz?

    I dont think this is the culprit though. From what I understand about electricy, the impeller would actually spin slightly faster in this scenario.

    It is possible the inverter is not stepping up our 110v to the correct euro 220v.

    Do you have a volt meter, so you can test the voltage output of the converter ?
     
Loading...