Noisy fluval 306

  • Thread starter roisinw
  • Start date
  • Thread starter
  • #1

roisinw

New Member
Member
Messages
21
Hi everyone,
I’ve just got a second hand fluval 306 external filter and as soon as we connect it to the tank it becomes very noisy and rattles. I’ve tried running it in a bucket and it doesn’t make a noise but as soon as I connect it back up to the tank it starts humming loudly again! Struggling to find a cause, I’ve tried making sure there’s no air in the tubes, priming, making sure all the seals are working but it’s still making the noise.
Anyone have any advice?
Thanks :)
 
  • #2

richiep

Fishlore VIP
Member
Messages
8,096
Have you checked your impeller for a broken fin,missing rubber grommet or grit or foreign object in propeller housing
 
  • Thread starter
  • Thread Starter
  • #3

roisinw

New Member
Member
Messages
21
richie.p said:
Have you checked your impeller for a broken fin,missing rubber grommet or grit or foreign object in propeller housing
Yep, I’ve checked all that and nothing seems to be amiss- it’s starting to drive me crazy now! :confused:
 
  • #4

richiep

Fishlore VIP
Member
Messages
8,096
Its still pumping a full bore
 
  • #5

Anthony1976

Active Member
Member
Messages
402
roisinw said:
Hi everyone,
I’ve just got a second hand fluval 306 external filter and as soon as we connect it to the tank it becomes very noisy and rattles. I’ve tried running it in a bucket and it doesn’t make a noise but as soon as I connect it back up to the tank it starts humming loudly again! Struggling to find a cause, I’ve tried making sure there’s no air in the tubes, priming, making sure all the seals are working but it’s still making the noise.
Anyone have any advice?
Thanks :)
Give it a few days it should quite down. I have that filter and after I clean it out it’s a bit rattly for a few days until all the air bubbles have worked their way out. Try rocking it side to side too to get air locks out.failing that you may need a new impeller and shaft as after a while the ceramic shaft wears a bit so the impeller isn’t a tight fit making it move side to side.
 
Top Bottom