29 Gallon Tank Noisy Fluval 207 Canister Filter

cmathew

I have a Fluval 207 Canister filter connected to a 29 Gallon Long Tank. For last few months the filter is very loud. Please see video here: New video by Charles Thomas Mathew

I do regular maintenance on this filter and also clean the impeller every 4 weeks. The filter is around 1 year old. I tried tilting the canister to make sure no air is trapped in it. I also cleaned the inlet and outlet.

Any idea what that noise is? Is it time to replace the impeller? Or is it time to change the media? My media trays are pretty full. I have added extra ceramic rings. But the trays sit flush.

Thanks, Charles
 

carsonsgjs

Welcome to the forum charles.

Sounds like its purging a lot of air - have you checked all seals to make sure they are tight? Any airstones in the tank near the intake? Any notable decrease in flow?

I don’t think the media will be causing that noise so I’d leave that alone for now.

Failing that, have you tried taking it all apart and setting back up?

Hopefully others may also be able to offer some suggestions.
 

cmathew

Welcome to the forum charles.

Sounds like its purging a lot of air - have you checked all seals to make sure they are tight? Any airstones in the tank near the intake? Any notable decrease in flow?

I don’t think the media will be causing that noise so I’d leave that alone for now.

Failing that, have you tried taking it all apart and setting back up?

Hopefully others may also be able to offer some suggestions.
Thank you very much!

There was an air stone near the filter intake . I moved the air stone to the other side of the tank. Now the filter is silent. Issue fixed - Awesome!
 

Similar Aquarium Threads

Replies
8
Views
178
carsonsgjs
Replies
4
Views
266
david1978
Replies
7
Views
1K
Nick Milford
Replies
24
Views
373
FishDin
Replies
5
Views
2K
xxbyamomentx

New Aquarium Filter Threads

Latest Aquarium Threads

Top Bottom