Noisy Canister Filter

  1. Nik74 Initiate Member

    Hi

    I've just progressed to a 180litre tank and am currently doing a fishless cycle.

    The filter that came with the tank is a Aqua One Aquis 1050 Series II. It seems really noisy to me, but not sure if that's normal.

    I'm used to a 21 Litre in tank filter that you can't hear at all.

    It sounds about as noisy as a fan on medium speed. Are you supposed to be able to hear them? or is my setup maybe wrong?

    cheers
    Nikki
     
  2. CichlidSWAGA Well Known Member Member

    did you prime the filter? it might just be that its trying to fill itself up but can't.

    can't say for sure i have never used this filter
     

  3. Nik74 Initiate Member

    There is a pump on the top. The instructions said to turn it on then pump it a few times until the tubes were full, so I think I did.

    Is there another way to prime?
     

  4. CichlidSWAGA Well Known Member Member

    well on my fluvals i fill up the canister part
     

  5. pirahnah3 Fishlore VIP Member

    There still could be some air in the tank. I would give that little pump another workout, watch the lines coming from and too the filter and see if there is any air in it or if it expels the air from the discharge rail.

    If it isn't air you may just have to take it apart and clean out the impeller
     
  6. Jaysee Fishlore Legend Member

    Have you tried rocking it back and forth to get the air out?
     
  7. Squirtle =) Member Member

    ^^^ +1 if you can even pick it up and give it a good shake, if this fails I would empty all the water in there out of the body and the hoses re prime it, re shake it if still noisy then once this all fails if so open it up and check the impeller make sure the O ring is lubed and the filter head is sitting onto the main body air tight.