New tank jitters

WendiWoo

So tonight I filled my new (used) tank on stand to water test and stand stability. Neeeerve racking! Then I put a canister filter together that I know nothing about to test its soundness. If all goes well by Sunday... I will be transferring another tank (everything) into this new one. I really hope I put the media in the filter properly!! I put charcoal, foam, bio media, floss and more foam. Lol. Does that sound right?
 

Attachments

  • 20210903_200325.jpg
    20210903_200325.jpg
    109.7 KB · Views: 18
  • 20210903_190200.jpg
    20210903_190200.jpg
    109.6 KB · Views: 19
  • 20210903_190153.jpg
    20210903_190153.jpg
    111.9 KB · Views: 18
  • 20210903_190148.jpg
    20210903_190148.jpg
    95.1 KB · Views: 20

carsonsgjs

Really depends on the filter but a typical set up will have the water hitting your mechanical media first (so sponges first ending with your fine floss), then biomedia (your ceramic rings or whatever you are using) then chemical media if needed at all (carbon etc). The idea is you want the water to be as clean as possible before it hits the biomedia, otherwise it can get clogged up.
 

WendiWoo

Really depends on the filter but a typical set up will have the water hitting your mechanical media first (so sponges first ending with your fine floss), then biomedia (your ceramic rings or whatever you are using) then chemical media if needed at all (carbon etc). The idea is you want the water to be as clean as possible before it hits the biomedia, otherwise it can get clogged up.
So it's a Rena Filstar I got used. I did find a video to help. It has starting at the bottom going up: course sponge, more dense sponge, bio media, then charcoal and lastly fine filter floss. I think I set it up backwards except the bio media lol. Now I'm going to have to figure out how to stop it omg . No better way to learn I guess.
I did it! That was very stressful lol. This is my first canister filter and it's quite intimidating. It seems a bit strong though for a 50 gallon. I got a bit of water after I unplugged it. But I re arranged the media and got it going again.
 

Similar Aquarium Threads

Replies
6
Views
134
cosermann
65 Gallon Tank Fishless cycling sucess
Replies
0
Views
47
Aquaricky
Replies
19
Views
244
CapitalGains
Replies
2
Views
123
DTurner
Replies
7
Views
253
Bettanewb78

Random Great Thread

New Aquarium Journal Threads

Top Bottom