New Odor

Tony M

Valued Member
Messages
208
Reaction score
118
Points
78
Experience
More than 10 years
I just switched my tank from an Mbuna tank to a planted community tank. I was using crushed coral as a substrate, now I’m using pool filter sand. I’m keeping about 20 fish. mollies, swords, Angels and a small Bristlenose. It’s a 46 gallon bow front running a Fluval FX4. So that’s more than enough filtration. I made the switch 10 days ago and I’ve just started to notice an odor. Cleaned the filter yesterday but the Oder is still there.

I’ve never kept live plants before. Could that be the cause? I put in 3 broad leaf sags, 2 lace java ferns and 2 Anubias.


Any suggestions would be welcome.
 
  • Thread starter
  • Thread Starter
  • #3

Tony M

Valued Member
Messages
208
Reaction score
118
Points
78
Experience
More than 10 years
Hey Angel,

Yes, maybe like a wet earthy smell. Not totally unpleasant, but once the wife starts to notice it, it may become an issue.
 

AngelTheGypsy

Fishlore VIP
Messages
5,107
Reaction score
5,992
Points
603
Experience
Just started
That’s to be expected with a planted tank. I never smell it until I open the top though, so if you don’t have one that could solve your issue?
 
  • Thread starter
  • Thread Starter
  • #5

Tony M

Valued Member
Messages
208
Reaction score
118
Points
78
Experience
More than 10 years
No, I’ve got a good top. I’m thinking it may be time to replace the sponges in the filter. I rinse them monthly but their at least 6 months old.
 
Toggle Sidebar

Aquarium Calculator

Follow FishLore!





Top Bottom