New eheim Jager thermostat heater not working?

Ap05

Hey guys just making sure I don't have a new dud heater. Got a brand new Eheim Jager thermostat heater 300w for my 125. Followed the instructions, set the temp to 85, and plugged it in horizontally as it won't fit vertically.

The light has yet to come on. My 200w is struggling to keep the tank at 80, so I'm wondering if it's just needing to take its time? I saw the heat coming off of it immediately after plugging it in, but after 30 minutes now, still no light or anything. Patience or help?
 

ryanr

Hi,
There's a trick to properly calibrating the Eheim's. The following video may help
 

Ap05

Such an easy fix. Thank you!

Well, now I had it calibrated to 80 which is what my thermometer constantly shows, and it turns off now before going to 85 which is where I'm setting it. I can't turn the red calibration up past 80.

Temperature looks like it has went up 1 or 2 degrees.

My 200w heater is still constantly on. Why are these things so complicated lol

Up to 82 now and it shut off again so it's at least working.

My 200w on the other side still has not shut off. I have it set on 86. Is this gonna run our electric bill up like crazy or do they not affect it that much? We had 4 tanks running previously. Only have this 125 and a 20 gallon now so lm hoping it isn't a big deal. I'll be getting a thermometer controller after Christmas.
 

jroe263

This is good to know! I have one sitting and waiting for my new 75 gal!
 

Thai Aquarium owner

Any heater will require to be on for at least 24 hours in a large tank.
Anything less than this, could give a false reading on the temp, as the water needs to be fully heated and stable.
 

DoubleDutch

They are terrible to calibrate, but when done they are great !
 

matsungit

My $15 temperature controller works flawlessly for over a year and I only had to replace a broken $1 probe once. I used a 300w Fluval heater on it, then a 150w Aqueon Pro, and now a 300w Reef Octopus titanium heating element.





Initially I thought it was off by -1 degree. Then after doing a thermometer test realized that my cheap thermometer was off and my controller was really spot on so I set the calibration back to 0..
 

Ap05

It doesn't seem like I can get it calibrated to as high as it needs to be. It only goes up to 80 and the tank is holding steady at 82 since setting it last night.

Should I unplug the 200w heater and calibrate it from there?

I'm thinking I'm gonna get a single catalina aquarium 300 or 500 watt heater after Christmas. Has a controller and everything already

So I got home and it was still at 82. I turned the temperature up to 88 on the dial.

The 200w heater is now starting to come off and on with the new eheim. Tank is now holding steady at 86. Seems like I got it set but will be keeping an eye on it.
 

Thai Aquarium owner

There is only one correct method to set a heaters temperature.
Set the dial on the low side by about 5 Deg C and heat the water for 24 hours, checking the temperature with a glass thermometer.
Then adjust up the temp on the heaters dial, and repeat the process, until the temperature required is achieved.
 

Similar Aquarium Threads

Replies
2
Views
631
83jase
Replies
8
Views
14K
llfish
Replies
14
Views
5K
sliderdkp
Replies
3
Views
712
virusmk
Replies
2
Views
1K
Ravynn

New Aquarium Heater Threads

Latest Aquarium Threads

Top Bottom