50 Gallon Tank My heater completely broke! What could have happend?

e_watson09

Fishlore VIP
Member
Messages
4,214
Reaction score
1,065
Location
Dayton, OH
Experience
More than 10 years
Well I bought a heater for my 50gal about a week or so ago and it was working fine at first. I had the tank at a really stable 78 for about a week and then last night I was doing a water change and noticed the water was REALLY cold so I look at the thermometer and it said 68! So I try to turn up the heater and it usually clicks on and has a little light but it didnt to anything so I tried to unplug it and plug it back in and still nothing so I pull it out and I see about an inch from the top it has crack in the glass that goes all the way around and then it is filled with water. How could something like this happen? I forget the brand but I know its one of the best you can buy from the pet store I bought it at. (It was the best that isn't made for a saltwater) and I don't want to go pay another 40 if its not going to work.

Oh and I thought maybe like a fish or something hit it really hard but I don't have any fish that are big enough for that. I have 3 parrots, 3 silver dollars, 3 green severms, and a 6in common pleco.

Any ideas as to what happend?

EDIT: Oh and the heater is in between the side of the tank and a filter so the fish can't really get to it anyways.
 

Shawnie

Fishlore Legend
Member
Messages
22,715
Reaction score
201
Location
Rochester NH
Experience
More than 10 years
did your water level drop lower than the heater? that could crack them very easily...
 
  • Thread starter
  • Thread Starter
  • #3
OP
e_watson09

e_watson09

Fishlore VIP
Member
Messages
4,214
Reaction score
1,065
Location
Dayton, OH
Experience
More than 10 years
nope I even after I did a water change I only pulled out maybe an inch of water from the top and the heater was still under the water.
 

Morgan111

Well Known
Member
Messages
622
Reaction score
1
Location
Carlisle, Ohio
Experience
More than 10 years
Could be several different things that caused this.... this is the reason I run all stealth heaters.
 
  • Thread starter
  • Thread Starter
  • #6
OP
e_watson09

e_watson09

Fishlore VIP
Member
Messages
4,214
Reaction score
1,065
Location
Dayton, OH
Experience
More than 10 years
its not it's a Hydor theo heater but I talked to the guy I bought it from today and he said he'd look at it and probably replace it.
 

New Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
76
Guests online
2,429
Total visitors
2,505

Aquarium Photo Contests

Aquarium Calculator

Top Bottom