Marineland Magnum 350 Loud Noise!

Bhopkins1311

Active Member
Member
Messages
330
Reaction score
23
Location
Fort Worth, Texas
Experience
1 year
I recently bought a 125 gallon tank, it came with a magnum 350 canister filter. It makes a awful loud sound. Like a vacuum cleaner or a blender. I left it on overnight thinking it just had air to get out. At the guys house I got it he had it running and it was quiet. Does anyone have any tips to quiet it down. Right now I just have a Penn plax 1500 on my tank and I took my marineland biowheel 350 off my 55 temporarily to help it get nitrate levels right quicker...tjat leaves my 55 with only aquatech 30-60 So the biowheel needs to go bad but I want double filtration.
 

max h

Well Known
Member
Messages
3,595
Reaction score
2,461
Location
Pensacola, Fl
Experience
More than 10 years
Something you can do is pull the filter apart the impeller is in the bottom of the Magnum 350 canisters, check for debris like sand and check to see if there's a small white plastic cup in the very bottom of the impeller well. Sometimes without the cup in the impeller well the impeller can wobble around. The good thing with both the Magnum 220/350 series filters all the parts are readily available from either Marineland or on internet stores.
 
  • Thread starter
  • Thread Starter
  • #3
OP
Bhopkins1311

Bhopkins1311

Active Member
Member
Messages
330
Reaction score
23
Location
Fort Worth, Texas
Experience
1 year
There's no peices under the impeller and I cleared it out
The magnet is a little scratched up though
I looked I don't want to spend 30 on a magnet when I could spend a little more on another filter
I don't feel like it's the magnet though
 

max h

Well Known
Member
Messages
3,595
Reaction score
2,461
Location
Pensacola, Fl
Experience
More than 10 years
The cover on the magnet get some wear on them. I have one that I put together from 3 different filters and only occasionally made noise. Normally that was when there was some air in the system. You can try the Marineland customer service either by eMail or phone, they are pretty good at helping out.
 
  • Thread starter
  • Thread Starter
  • #5
OP
Bhopkins1311

Bhopkins1311

Active Member
Member
Messages
330
Reaction score
23
Location
Fort Worth, Texas
Experience
1 year
Bhopkins1311 said:
There's no peices under the impeller and I cleared it out
The magnet is a little scratched up though
I looked I don't want to spend 30 on a magnet when I could spend a little more on another filter
I don't feel like it's the magnet though
I called them they are sending me a new impeller system so we will see
 

New Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
116
Guests online
1,896
Total visitors
2,012

Aquarium Photo Contests

Aquarium Calculator

Top Bottom