Im not sure what's wrong with my Emperor Tetra?

Newbie94

Hi I'm new to the Hobbie with a 15 gallon cycled tank, I have decided to stock the tank within 2 weeks to save time/money on quarantining each set of fish. Most of the fish are doing will, with 2 exeptions 1) little ich on 2 of the cardinal tetras (which I have already been treating for a week) their behavior seems fine, they eat and socialize as normal. 2) 1 of my purple emperor tetras started to get a bit aggressive towards the other fish when they got near him one day, I just kept an eye on it because there wasn't any actual fighting. Then a couple days later, he started to swim near the filters output. And wasn't eating as much, by this point I had just started treating the ICH.

After a couple days, I noticed his color was faded on the front half for his body, to a beige color. Then, since I had been keeping the lights off a bit more to help them recover, I started inspecting them with a small flashlight, and what I saw look a bit like what I assume velvet would look like on this kind of fish. Since the treatment I'm giving for ICH also treats velvet, I decided to wait a few days, but his color is still super pale with a bit of beige. The ICH seems to be going away (I'm assuming because I bumped the heat up, the life cycle is quicker and the treatment is working). The Rasboras, corydoras and other emperor tetras are all fine, it's just a couple cardinals with ICH and this one Emperor. I'm not sure it's velvet anymore because, unlike the cardinal he doesn't seem to be getting much better, and the tank has been getting treated for a week (I've had him for 2). The only plus sides are 1) whatever he has doesn't seem to have passed to any of the other fish and 2) He's still alive with energy to swim around a bit.


Levels:
Ammonia, NO³ and NO²: 0
GH:0
KH: 6
pH: 7
Cl²: 0
Temp: 82°F
25% water changes every 3 days to remove ICH

I have stocked the tank with the following:
3 purple emperor tetras,
4 cardinal tetras,
3 corydoras,
4 Harlequin Rasboras

Note: I have been trying to find more Rasboras but due to covid no one seems to have (I bought the last 3 from the 1 shop that had them. Also, planing to get at lease 2 more cardinals to meet to minimum recommended without spiking ammonia. Will quarantine them for a couple weeks when I'm finally able to get them.

I have attached a couple pictures of the emperor. The picture with the H.rasboras is one of the healthy ones, for easy comparison (I couldn't get them in a picture together.

Does anyone have an idea of what this may be?

20210726_093546.jpg
 

Attachments

  • 20210726_093447.jpg
    20210726_093447.jpg
    116.7 KB · Views: 14
  • 20210726_093634.jpg
    20210726_093634.jpg
    199.4 KB · Views: 13

Similar Aquarium Threads

  • Question
Replies
5
Views
484
MacZ
Replies
4
Views
401
LouPey
  • Question
Replies
4
Views
265
bluelights
Replies
3
Views
121
Zach72202
Replies
1
Views
128
veggieshark

Random Great Thread

New Tetra Threads

Latest Aquarium Threads

Top Bottom