I think my test kit is broken

  • Thread starter

molliesrevil

New Member
Messages
6
Reaction score
0
Points
151
My testing solution is consistently saying I have ammonia in my water ever since I added peat to the filter. It is saying .5 ppm consistently. My readings otherwise are ph 6.4 Ammonia 0.5 Nitrite 0.0 Nitrate 5.0 Hardness 3-4. Water has been cycled since March 10th. There is 0.3% salt level in the water (1/10th ocean salinity). Advise please. The test kit is a liquid/powder mix.
 

Butterfly

Fishlore Legend
Messages
22,864
Reaction score
120
Points
518
Experience
More than 10 years
Sounds to me like your tank isn't finished cycling. It can take 6-8 weeeks and longer sometimes to cycle.
Now why do you have peat and salt in your water? (just curious) also what kind of test kit?
Carol
 
  • Thread starter

molliesrevil

New Member
Messages
6
Reaction score
0
Points
151
slowly getting rid of the salt, got rid of the mollies. Peat for the acidity and softness tetras and angels like...... A cheap testkit from petco. I know the tank is cycled, because i already had the ammonia and nitrite surges a while ago.
 

Butterfly

Fishlore Legend
Messages
22,864
Reaction score
120
Points
518
Experience
More than 10 years
Your angels and tetras will adjust to about any pH as long as they are acclimated slowly. Neither of these like salt at all. My angels and tetras are in 7.2-7.4 pH and have been for years . The angels breed regularly. The less you mess with your water the less fluction in parameters you will have. Fluctuation in parameters cause stress and is what kills more fish than just about anything else.
Don't know how water test kits react to peat in the water.
Carol
 
Toggle Sidebar

Aquarium Calculator

Aquarium Photo Contests

Follow FishLore!





Top Bottom