I had a testing accident.. HELP!! Help

  1. bruiser

    bruiser Member Member

    Messages:
    351
    Location:
    Ont. Canada
    Ratings:
    +4
    Hey, I was testing my water for ammonia, with the API Freshwater Masters kit.
    The vile had 5mL of water and 8 drops of the bottle #1 ammonia solution in it (bottle doesn't tell me the contents..) And it got knocked into the water.

    The fish arn't showing any signs of stress or anything, but it says in the book, not to put solution into the water, but it does not say what to do, if it happens..

    Does anyone know what I should do next? will the filter clean it up? do I need to empty my tank, clean everything and start all over again? any help would be great!!

    thanks!
    Chris.
     

  2. Meenu

    Meenu Fishlore VIP Member

    Messages:
    7,468
    Location:
    South Central Texas
    Ratings:
    +75
    chris, I'm trying to do a google search but no luck so far. I'll keep trying.

    If it was me, I'd do a 50% water change and leave it at that. :;dk
     

  3. ray_sj

    ray_sj Member Member

    Messages:
    376
    Location:
    San Jose, CA, USA
    Ratings:
    +7
    The chemicals may not hurt the fish, but personally, I'd do a few significant water changes just in case..
     
  4. OP
    OP
    bruiser

    bruiser Member Member

    Messages:
    351
    Location:
    Ont. Canada
    Ratings:
    +4
    okay, thanks a lot for the help. I'm gonna start changin water right now!
     
  5. Aquarist

    Aquarist Fishlore Legend Member

    Messages:
    46,999
    Gender:
    Male
    Location:
    On the beach
    Ratings:
    +273
    Hello Bruiser. I'm not sure there is much that you can do other than the water change. Sorry you had to experience this. Here is a # you can call for API, toll free. 1 800 847 0659. If you want to send them an email: www.aquariumpharm.com. It wouldn't hurt to see what they may have to say.
    Best of luck. I hope your fish are going to be ok.
    Ken
     
  6. OP
    OP
    bruiser

    bruiser Member Member

    Messages:
    351
    Location:
    Ont. Canada
    Ratings:
    +4
    Hey all, just an update..

    Last night shortly after the spill I did a 50% water change, and put new carbon in my AC300. Tested my water this morning, and nothing is showing up strange.. (I know i'm not testing for whatever the solution is specifically, but its not throwing anything else off either.)

    All the fish are looking good, no signs of illness, or strange behavior.

    I'm going to do another 50% water change in a few minutes.. Right now I'm emailing API just to see what they have to say.. I'll let everyone know what they tell me.

    thanks for all the help and advice!

    Chris.
     
  7. Aquarist

    Aquarist Fishlore Legend Member

    Messages:
    46,999
    Gender:
    Male
    Location:
    On the beach
    Ratings:
    +273
    Hello Bruiser. Glad to hear that everyone is well! Keep us posted.
    Ken
     
  8. Meenu

    Meenu Fishlore VIP Member

    Messages:
    7,468
    Location:
    South Central Texas
    Ratings:
    +75
    I'm glad it all looks okay. :)
     

Share This Page