How Are My Plants Looking?

Discussion in 'Aquarium Plants' started by IceForever, Apr 23, 2019.

  1. IceForeverValued MemberMember

    Hello everyone,

    I’ve had my tank up and running for around 8-10 months now and have slowly transitioned out almost all of my plastic fake plants now. I am a little worried about some of my plants, though, as they seem to be showing signs of deficiency. I started dosing ferts when some of the leaves started looking really bad and getting overrun by algae, and they have started looking better but I am still a little concerned and want to make sure everything is ok.

    The ferts I am using are Dennerle’s perfect plant system, so s7 vitamin, v30, and e15, as well as scapers green and their plant elixir. The three that are weekly I divide the dose in to three 1/3 dose additions on Monday/Weds/Friday.

    04168629-4F7A-4592-8B68-8BA78DFF4053.jpeg4EA6076B-DA55-4FB1-B522-4D25226A89A5.jpeg83AEB8A7-D323-4617-B4C7-87DF270A9B89.jpeg41256DDB-6E82-48F0-9E7A-EFB0ECA32391.jpegF0DDF163-A5A5-4911-ACED-0F472F137A6E.jpeg
     
  2. blue velvet keeperWell Known MemberMember

    nice looking tank i think the algae problem is fine in there in my tank i throw some shrimp and snails depending on the stock

    Edit: what stock is there
     




  3. PheonixKingZWell Known MemberMember

    I’m sorry, are we talking about the fake plants? Or live plants, that are decaying?:)
     




  4. Thunder_o_bFishlore VIPMember

    Are you using root tabs for the Amazons? They are heavy root feeders.

    I also am seeing what I believe is an iron and potassium deficiency.
     
  5. IceForeverValued MemberMember

    Thank you, I do have shrimp and snails in the tank. Here is a link to my intro post with my full stocking list

    Live plants. I only have a few fake ones left bc I am afraid to move them due to how my swords roots run through them

    That’s what I thought it looked like as well, I WAS due for the tanks next e15 feractive (iron fert) supplementation yesterday, so hopefully it was just depleted a little sooner given the new plants I’ve put in. Clearly that new crypt hogged the nutrients:emoji_joy:

    It literally got planted as one big crypt, and since then has literally just been shooting up new plants like crazy. I have like 6-7 plants out of this one big girl(pics out of order haha sorry) 55E86F62-5B99-4897-B5AB-E5204A6FFECD.jpeg60A7A8D8-34F5-4A72-80BE-5E43FDE32A79.jpegB0DD49C1-AF54-40F7-8D32-99344F8B5163.jpeg

    You can see in those pics, though, the extent that my old crypts have melted...they were doing so well and getting so big...do they really get that traumatized by having their roots moved around? I have messed w them a bit here and there but have never had this kind of issue...this reminds me of when I first brought them home.
     
  6. kallililly1973Well Known MemberMember

    U can cut or remove the damaged sword leaves to allow for new fresh growth.. did u say u were using root tabs they should b used for swords especially in a gravel tank
     
  7. PheonixKingZWell Known MemberMember

    Just cut away the decaying leaves, how are you growing plants, in those marbles/gravel?:)
     
  8. IceForeverValued MemberMember

    951108CF-8E9C-4DA7-B175-8664AEC4A318.jpeg


    These are the ferts I use, plus their e15 feractive iron tabs which I just used the last of yesterday so I don’t have the box lol.

    S7/scapers/elixir are once a week which I break up in to 1/3 doses every M/W/F, nutriballs are every 6 months, v30 and e15 are every 4 weeks but spaced two weeks apart (ie the 15th of every month for one and the 30th of every month for the other)
     
  9. PheonixKingZWell Known MemberMember

    Sounds good!! I can’t see why they aren’t growing.....?
     
  10. IceForeverValued MemberMember

    As long as they have decent root structure when I put them in they seem to have been doing alright...to be honest I haven’t even dosed ferts at all up until recently...just the water changes -which are actually super light- has been sufficient since I had a lot of fake plants, but now that I have almost all real ones I guess they are stripping out the water too rapidly and I have to dose now
     
  11. PheonixKingZWell Known MemberMember

    Makes sense!! To be honest with you, I have never really kept any plants except Anacharis plants!!:)
     
  12. IceForeverValued MemberMember

    Everything is growing, except for the two old crypts that I messed with and had all their beautiful leaves rot away

    They each still have one or two good leaves left which were new growth, so I am hoping that they will turn around soon.

    Oh and I somehow managed to fail with Anachris, which people seem to think is impossible...but they were fresh clippings with no roots so when I put them in to my gravel they had a hard time developing I guess...out of the lot, I have one or two good ones left.

    My angel cories and SAE are also jerks and love to rip stuff out of the ground
     
Loading...