Hob Filter Help?

  1. oOturquoiseOo

    oOturquoiseOo Well Known Member Member

    I have a tiny hob filter that I got on ebay. It is for my 2 gallon jar. I would really love to make it work.

    The problem is that the water isn't being drawn up into the intake. And sometimes all of the water in that part of the filter (I put it there to try to start the filter) will just all of a sudden go out of the filter. It is not leaking out of the bottom (I checked!) it seems like it all of a sudden starts working but it doesn't draw up water. I can see the impeller spinning around in there. So strange.

    Anyone have any ideas I can try? Thanks!
     
  2. DylanM

    DylanM Well Known Member Member

    Have you primed it properly by filling it up with water, and then turning it on? Also, what do you plan on keeping in a 2 gallon jar?
     
  3. OP
    OP
    oOturquoiseOo

    oOturquoiseOo Well Known Member Member

    Yes, I filled it up and then plugged it in.

    I am hoping to do a few shrimp. I know I can run a sponge filter but I was hoping for a hob just to free up more space in the tank.
     


  4. THE HABITAT

    THE HABITAT Well Known Member Member

    try to add a little more water while it is coming up the intake tube it might just need to get over that final hump for the suction to get flowing...just a suggestion
     
  5. THE HABITAT

    THE HABITAT Well Known Member Member

    or possibly remove the intake tube and hold your finger on the bottom of it and fill with water and try to get it back into position...is an Aquaclear?
     
  6. OP
    OP
    oOturquoiseOo

    oOturquoiseOo Well Known Member Member

    Thank you. I've tried both those ideas already :(

    I'm not sure the brand. It is from China.
     
  7. THE HABITAT

    THE HABITAT Well Known Member Member

    can u insert a pic....must be just that the propellor isnt spinning strong enough....i believe those systems are pretty cut n dry...im sure u disassembled it and made sure no rocks or sand or debris has gotten into the intake tube....
     
  8. OP
    OP
    oOturquoiseOo

    oOturquoiseOo Well Known Member Member

    Thanks. I will get a picture in the morning. It's looking a little like Frankenstein's monster right now. My jar is round and the filter did not fit so I hacked it up and glued it back together. Haha!

    I had to change the intake as well because it couldn't fit over the rim of the jar. But it didn't work with the original intake either. I thought it was because it was so far out of the water.

    Hopefully I can get this working. If not I'm only out $10 and I'll have to go with the sponge filter (even though I don't really want to)