High tech 20g long

aquagirllover

Member
Hey guys, I recently set up my 20g long high tech aquarium and everything is thriving wonderfully! I have just plants as I am properly cycleing my tank. I used a filter off my established 46 gallon bow front tank (although I DONT I tend in adding any fish or invertebrates right away) I just wanted to speed up the process a bit. Any way I have had awfully cloudy water for about a week now and I understand it is likely a bacterial bloom being a good thing just pondering, how long will the cloudiness last? Is it different for everyone? Will activated carbon help or slow down my cycling process? Any other tips for getting this tank in pristine condition before I add my shrimp and micro fish? Thanks again
 

SaltyPhone

Member
If you used a filter off an established tank it’s already”cycled”. Are you pumping ferts into the tank?
 
  • Thread Starter

aquagirllover

Member
  • Thread Starter

aquagirllover

Member
Personally I don’t believe in an “instant” cycle I feel as though it helps but not the end all be all of solutions for cycling a tank.
 

SaltyPhone

Member
I totally get that; every tank is different the cloudiness is likely just nitrifying bacteria dying off as a result of lack of nitrogen to digest. Keep pumping ferts into the tank on a consistent basis and when you have new plant growth you should be good to go! Sorry in order to address the other question I’ve never used carbon other than to clear water of meds.
 

Latest threads

Top Bottom