Help! White Fuzzy Stuff!

  • Thread starter

perrydaplatypus

Valued Member
Messages
76
Reaction score
8
Points
43
This stuff is on one of my decorations nearest the filter. I am a little ways into a fishless cycle. I've brought my tank up to 2ppm ammonia and in about 6 days it was down to .25 ppm so I brought it back up to 2ppm anf again in like 6 days it was down again. So I brought it up to around 3 or 4 ppm and it's been stuck there for approximately 5 days. I also have not seen any nitrites or nitrates yet. I don't know what's going on or what this stuff is on decoration just noticed it today.
20180417_205307.jpg
 

sfsamm

Well Known Member
Messages
1,926
Reaction score
1,264
Points
198
Looks like either hair algae or brush algae. I'd recommend finishing your cycle without lighting just because it's easy to black out either of those now while there's no fish that you want to see.
Cover the tank and prevent all light for three days then check, if it's still there go another three in blackout. Should be gone.
 
  • Thread starter

perrydaplatypus

Valued Member
Messages
76
Reaction score
8
Points
43
sfsamm said:
Looks like either hair algae or brush algae. I'd recommend finishing your cycle without lighting just because it's easy to black out either of those now while there's no fish that you want to see.
Cover the tank and prevent all light for three days then check, if it's still there go another three in blackout. Should be gone.
Thank you
 
Toggle Sidebar

Aquarium Calculator

Aquarium Photo Contests

Follow FishLore!





Top Bottom