Having problems with my tank

  1. Craig Well Known Member Member

    im havin big problems with my tank at the mo all my fish r dying on me and the water seems 2 hav like a polluted effect on the surface!!! i hav done water changes but nothin is workin im stressed out makes me think that this hobby is not 4 me!!! iv had 6 fish die now in a period of 2 weeks or less
     
  2. Isabella Fishlore VIP Member

    Re: so............

    Craig, if you can, please check your ammonia, nitrite, and nitrate levels. Also check your pH and temperature. If ammonia and nitrite are present even is small amounts that is why your fish are dying. Also, high nitrate may cause death as well as diseases. When did you put your fish in the tank? That is, how soon after you set up your tank did you put the fish in there? Because you usually have to wait about a month after setting up a tank before you buy fish. The tank needs to be cycled first. If you know about cycling then disregard my post, but if not, please read up on it. There is a lot of information on this and other websites on cycling the tank.

    However, if all your water parameters are fine, then I don't know what's causing these deaths. Maybe a disease. Did you observe any changes in your fish's behavior or any growths on their bodies? Or perhaps you have some decor that has some toxic chemicals in it? Is all your decor and gravel specifically for aquaria? Just some thoughts.
     

  3. Janmitch22 Member Member

    Looks like you and nap83 have the same deal going on. Gunnie mentioned a necessity for surface agitation. Do you have that? Read up on nap83's post and see if it applies. If it doesn't, then I don't have a clue! lol
     
  4. Butterfly Moderator Moderator Member

    Craig don't panic yet, lets figure this out and get you back on track. Isabella asked some good questions and as soon as we get those answers maybe we can help you. Hang in there, your not alone, we're here to help.
    Carol
     

  5. Craig Well Known Member Member

    i have no ammonia in my tank i got the bright yellow goin on my test card 0ppm and my pH is 6.8 so why r my fish still dyin i lost another cory this mornin
     
  6. Butterfly Moderator Moderator Member