Halp! Crazy Algae In My Betta Tank

Pescado_Verde

Member
I don't even, what in the world??

This crazy stuff appeared just in the last week, I did a water change last weekend and it wasn't there then so it has bloomed and grown to its current size just in that short period. The tank had/has green algae on the glass but this is like ectoplasm coming out of some Wisteria.

20180930_200911.jpg

Thoughts?
 

FishFor2018

Member

Jellibeen

Member
I have this stuff all over my betta tank too! I admit i’ve been kinda lazy about it. I have been manually removing it as best I can. I hope someone can offer advice on how best to deal with it.
 
  • Thread Starter

Pescado_Verde

Member
I guess I could try the Nerites in there. When I had the Betta that lives in that tank in a smaller one I put in 2 Nerites and he'd harass them a bit. He might leave them alone in this larger tank. I just bought a half dozen snails but put them all in my planted 55. They've all vanished in the jungle, lol. I'll keep an eye out for 'em and if I see one I'll drop it in.

Really weird though how fast it bloomed. Do you know what type it is?
 
  • Thread Starter

Pescado_Verde

Member
Jellibeen said:
I have this stuff all over my betta tank too! I admit i’ve been kinda lazy about it. I have been manually removing it as best I can. I hope someone can offer advice on how best to deal with it.
It just showed up out of nowhere. I've had fish tanks off and on for years, just Betta's in small tanks but still, I've never seen this stuff before. Crazy looking. Hope I don't spread it!
 

Jellibeen

Member
Mine is a newer tank that I just put a nice light on, so it wasn’t out of nowhere on my part. Luckily I only have it in one tank! I’ve been stirring it up and vaccuuming it out.
 
  • Thread Starter

Pescado_Verde

Member
Jellibeen said:
Mine is a newer tank that I just put a nice light on, so it wasn’t out of nowhere on my part. Luckily I only have it in one tank! I’ve been stirring it up and vaccuuming it out.
This particular tank if fairly new, maybe a month? Just seems weird that just a week ago there was no hint of it, did a water change and BAM! Tank funk!
 

Betta'sAnonymous

Member
Weird. Too much/not enough tanklight or indirect sunlight?
 
  • Thread Starter

Pescado_Verde

Member
Betta'sAnonymous said:
Weird. Too much/not enough tanklight or indirect sunlight?
Not sunlight, it's in a far corner away from any windows but there is a pole lamp next to the rack right at that height. Bit weird that it didn't bloom on that end of the tank closest to the lamp though. I've been meaning to put the Betta tanks on timers for the lights and I've been a bit hit or miss on consistent lighting for both of them (the other one sits below the one with the algae but below the level of the lamplight).
 

Betta'sAnonymous

Member
Hmmm...havent had algae at all in my betta tanks except when I had the one by the window. Its still there algae free now that I put a back cover on the tank to keep the sun out
 
  • Thread Starter

Pescado_Verde

Member
I pinched off the stem of the plant that the mass was growing off of. Carlos looked at me as if to say "HEY! That was MINE!".

We'll see if it comes back.
 
Top Bottom