Hair algae issues

SuperSword48
Member
For the past week I have been having crazy amounts hair algae growth in my 20 gallon tank. I believe this was because I had about 40 ppm of nitrates in the water which has since been lowered to 5. All other parameters are normal and have been checked. I have hard water and a ph of 7.8. My light is on for 10 hours and is a nicrew light. I also have hornwort, 3 Java ferns and Java moss in the tank. I need some suggestions on how to get rid of it and stop it’s growth. My tank is stocked with 10 harlequin rasboras, 10 Pygmy corydora, and 2 thick lip gourami. It also has bladder snails in it.
 
Seamus111
Member
How close is the tank to a window..... or even sunlight going into it from across the room? I would turn the light down to 8 hours. Clean what you can off everything. If it persists, make the tank dark for 3 days. If it still wont go away, try a bit of 3% Hydrogen Peroxide, directly on the algae. Hydrogen Peroxide is H2O2, similar to H2O, oxygen. But has one more molecule of oxygen. It is used in stagnant pools of water where oxygen is low, to keep fish alive, in many areas of the world. Remove or turn off your filter. If you have a syringe then fill it and squirt it directly on the algae. In roughly 24 to 48 hours, the breakdown of the H2O2 will become water and oxygen. About 10 to 15 ml per 10 gal of water can be used. You can also do a plant and hardscape dip. Remove the plants and wood etc and place in a bucket. 3 ml of H2O2 per 1 gal of water for 5 to ten minutes. And no....... even in the aquarium with plants and fish and shrimp, I never had a problem at all by adding/squirting the Hydrogen Peroxide directly.
 
JLAquatics
Member
SuperSword48 said:
For the past week I have been having crazy amounts hair algae growth in my 20 gallon tank. I believe this was because I had about 40 ppm of nitrates in the water which has since been lowered to 5. All other parameters are normal and have been checked. I have hard water and a ph of 7.8. My light is on for 10 hours and is a nicrew light. I also have hornwort, 3 Java ferns and Java moss in the tank. I need some suggestions on how to get rid of it and stop it’s growth. My tank is stocked with 10 harlequin rasboras, 10 Pygmy corydora, and 2 thick lip gourami. It also has bladder snails in it.
What do you dose for fertilizer in this tank? This includes column fertilizers and root tabs.
 
Freshfishguy
Member
SuperSword48 said:
For the past week I have been having crazy amounts hair algae growth in my 20 gallon tank. I believe this was because I had about 40 ppm of nitrates in the water which has since been lowered to 5. All other parameters are normal and have been checked. I have hard water and a ph of 7.8. My light is on for 10 hours and is a nicrew light. I also have hornwort, 3 Java ferns and Java moss in the tank. I need some suggestions on how to get rid of it and stop it’s growth. My tank is stocked with 10 harlequin rasboras, 10 Pygmy corydora, and 2 thick lip gourami. It also has bladder snails in it.
How recently did you set up this tank? Hair algae is common in newer/newly cycled planted tanks. Excess nitrates could be the cause, however most likely you have the lights on for way too long. I would actually recommend going down to 6 hours at the most, maybe even 5, while the hair algae is bad. Then I’d do some treatments to help the tank beat it, let it balance, and then slowly raise the lighting by 30 minutes-1hr a week until you encounter algae issues or hit 8 hours.

This article is really helpful for algae issues. I consider it necessary knowledge for planted tankers:https://www.fishlore.com/aquariumfi...-and-algae-myths-in-the-planted-aquarium.118/.
 
JeremyW
Member
The standard advice for reducing algae is to reduce lighting and nutrients. That's a good starting point for a lot of people, but it only works if the problem is an excess of those things, and that's not always the case.

My green hair algae problems are usually tied to poor plant health. If my lighting and/or fertilizers aren't keeping my plants healthy and growing, then I end up with an algae problem. I have never had luck beating green hair algae by reducing light and/or nutrients. In fact, I usually have to go the other way.

If I were in your shoes, I'd be cautious reducing light to less than 8 hours, and I'd take a good hard look at your plant health before anything else. Pay attention to your hornwort in particular. That's your fast grower, and that's the plant you need to focus on. So how does it look? It is healthy? Is it growing? If not, then that's likely the source of your problem. It could be suffering from a deficiency. Hornwort can be fairly demanding for nutrients, so if your fertilizing regimen is lacking something, then it could be suffering. That would lead to an algae problem.

I'd rule out poor plant health before trying anything else.
 
  • Thread Starter
SuperSword48
Member
JLAquatics said:
What do you dose for fertilizer in this tank? This includes column fertilizers and root tabs.
I don’t use any because all my plants seem to be growing.
JeremyW said:
The standard advice for reducing algae is to reduce lighting and nutrients. That's a good starting point for a lot of people, but it only works if the problem is an excess of those things, and that's not always the case.

My green hair algae problems are usually tied to poor plant health. If my lighting and/or fertilizers aren't keeping my plants healthy and growing, then I end up with an algae problem. I have never had luck beating green hair algae by reducing light and/or nutrients. In fact, I usually have to go the other way.

If I were in your shoes, I'd be cautious reducing light to less than 8 hours, and I'd take a good hard look at your plant health before anything else. Pay attention to your hornwort in particular. That's your fast grower, and that's the plant you need to focus on. So how does it look? It is healthy? Is it growing? If not, then that's likely the source of your problem. It could be suffering from a deficiency. Hornwort can be fairly demanding for nutrients, so if your fertilizing regimen is lacking something, then it could be suffering. That would lead to an algae problem.

I'd rule out poor plant health before trying anything else.
The hornwort sheds a lot but it also grows about 3 inches weekly and after increasing my light from 8 to 10 and it seemed to be doing better. I believe the rest of the plants are healthy.
Freshfishguy said:
How recently did you set up this tank? Hair algae is common in newer/newly cycled planted tanks. Excess nitrates could be the cause, however most likely you have the lights on for way too long. I would actually recommend going down to 6 hours at the most, maybe even 5, while the hair algae is bad. Then I’d do some treatments to help the tank beat it, let it balance, and then slowly raise the lighting by 30 minutes-1hr a week until you encounter algae issues or hit 8 hours.

This article is really helpful for algae issues. I consider it necessary knowledge for planted tankers:Algae Management and Algae Myths in the Planted Aquarium.
The tank has been set up about 2 months ago
 
Freshfishguy
Member
SuperSword48 said:
I don’t use any because all my plants seem to be growing.

The hornwort sheds a lot but it also grows about 3 inches weekly and after increasing my light from 8 to 10 and it seemed to be doing better. I believe the rest of the plants are healthy.

The tank has been set up about 2 months ago
Yeah that’s a common time for hair algae to pop up. Plant health is for sure possibly the #1 reason algae appears. I would recommend at least a basic all in one fertilizer like easy green by Aquarium Co-Op. Plants simply cannot be 100% healthy without fertilizers, as they can’t get all the nutrients they require just from fish waste and what is already in the tank. I would also step up water changes while the hair algae is bad and manually remove as much of it as possible. Excess organic waste in the water column could very well be causing/contributing to the algae bloom.
 
Pfrozen
Member
Using no ferts will cause hair algae. Fill a barebottom tank with water and nothing else and hair algae will appear if your lighting is too high.

Buy an all in one fertilizer and reduce your lighting period to 7 hours. Dose with excel for a few days. That's pretty much all you need to do. Hair algae is one of the easiest algaes to deal with

Your plants aren't demanding so you dont need anything too concentrated. Thrive S or Thrive C will work fine. Tropica is also good for undemanding plants. I only dose potassium and trace minerals in tanks like yours

Regards
 
kbn
Member
Ukw, you can use a longer photoperiod with an hour or two of gap in the middle. Helps the plants and algae doesn't get much of a hold. This is still pretty controversial but it works for many many people.
 
  • Thread Starter
SuperSword48
Member
Freshfishguy said:
Yeah that’s a common time for hair algae to pop up. Plant health is for sure possibly the #1 reason algae appears. I would recommend at least a basic all in one fertilizer like easy green by Aquarium Co-Op. Plants simply cannot be 100% healthy without fertilizers, as they can’t get all the nutrients they require just from fish waste and what is already in the tank. I would also step up water changes while the hair algae is bad and manually remove as much of it as possible. Excess organic waste in the water column could very well be causing/contributing to the algae bloom.
Got it thank you. I will start dosing fertilizer and I did a 50% water change a few days ago. I’m still trying to figure out a good water change schedule but I’ll make sure to keep a good eye on it over this time.
 
  • Thread Starter
SuperSword48
Member
Pfrozen said:
Using no ferts will cause hair algae. Fill a barebottom tank with water and nothing else and hair algae will appear if your lighting is too high.

Buy an all in one fertilizer and reduce your lighting period to 7 hours. Dose with excel for a few days. That's pretty much all you need to do. Hair algae is one of the easiest algaes to deal with

Your plants aren't demanding so you dont need anything too concentrated. Thrive S or Thrive C will work fine. Tropica is also good for undemanding plants. I only dose potassium and trace minerals in tanks like yours

Regards
I have flourish do you think that’ll work? Also what should I do to get the algae gone once I have it more under control?
 
Top Bottom