H.O.T. Magnum 250 Problems?

  1. fish gazer Member Member

    I recently purchased a Magnum 250, problem is, it was pushing out so many water bubbles, at one point I couldn't even see anything in the tank!

    I took it apart, re-lubricated all the parts I could think of, multiple times, still the same problem! I took a look at the inflow/outflow tubes and noticed that there was water leaking from it, I siliconed it, tried it the next day, same thing, tank full of bubbles again!

    I called the store up, they said air leaks are apparently a "known issue" caused by defects in the cover/tubes and they will send the pieces out to me asap.

    Has anyone had these issues? I know it's supposed to just push water out with no bubbles. I'm just waiting for my pieces and I'll try it again, anything else with these filters I should know about???
     
  2. Aquarist Fishlore Legend Member

    Good morning,

    Before putting the filter on the aquarium, make sure the filter itself is completely full of water, to the point it overflows a bit when you put the lid on. Set the filter on a towel on the floor, make sure it's level and fill it up with tank water, let it overflow a bit, replace the lid, then place it on the tank. This should eliminate the bubbles. Expect a few bubbles at the initial start up but they should stop.

    Be sure to wipe the filter off before plugging it in and make sure your hands are dry!

    Good luck!

    Ken
     

  3. fish gazer Member Member

    Thanks!

    I received the new pieces, didn't even have to send mine back! I'm going to try it out tonight and fill it with more water this time, I filled it just above the cartridge last time. I'll let you know how it goes, fingers crossed!
     

  4. fish gazer Member Member

    So. I opened up the box with the new pieces. Very disappointed!

    The outflow valve was curved out of shape and had a gap between the piece and does not click into place, I tried it anyway. A tank full of bubbles again!!!

    I will be making a phone call in the morning... So disappointed..
     

  5. Lucy Moderator Moderator Member

    Well, that's a bummer.

    Hopefully their customer support can help.

    Let us know how things work out.
     
  6. fish gazer Member Member

    Last night, we took apart the canister, messed around with it a little, and tried my original siliconed part again, it worked!! Once in a while there's tiny bubbles but really not noticeable. I didn't want to stick with that solution because I siliconed it, I can no longer swivel the outflow tube.

    I still called Big Al's again this morning to tell them about the second damaged valve that they sent to me. She said that she's heard of 5 cases like mine and would send another cover with the tubing and if it still didn't work to maybe return the whole unit and consider a different filter.

    I really like what I've read about the water polishing aspect of it so, I hope it works out. We shall see.


    Sent from my cell phone.