10 Gallon Tank Green Cloudy Water While Cycling?

sglider12
Member
I started cycling a 10 gallon yesterday using some old filter media and some fish flakes. This morning I woke up and the tank is green, cloudy, and stinks. I walk into the room and the smell is overwhelming. Do I need to do a water change? Or is the green abnormal?
 
Aquarist
Member
Hello sglider. The algae is normal and should subside over time with water changes. I keep my lights on for 12 hours per day no more no less. If you aren't using activated carbon in the filter I suggest adding some. It will take care of the odor. I change my carbon every 3 weeks. Too, you may want to check the level of your nitrAtes.
Good luck with the new tank!
 
  • Thread Starter
sglider12
Member
Ah thanks for the reply. I'm planning on to the pet store today anyway to pick up some more carbon filters and a new test kit. I also need more bulbs....

But yeah thanks for the info!
 
Shawnie
Member
is it near a window for sunlight? that's pretty fast as in overnight to change that much.....
 
  • Thread Starter
sglider12
Member
Shawnie said:
is it near a window for sunlight? that's pretty fast as in overnight to change that much.....
No it's not. It doesn't even have lighting right now due to the fact that the bulbs are out. I just picked up some more bulbs but I'm not sure if I should put them in there.

I did a nitrate and nitrite testing. Nitrate was off the chart. The nitrite result was a little difficult to read. I couldn't tell if it was 0 or off the chart.

Should I do a water change?
 

Latest threads

Top Bottom