Fluval AquaClear 50

rossclan151
  • #1
I changed over to the Fluval when my Marineland dual bio-wheel died about 6 months ago. I am super unhappy with this power filter and need a solution. I clean the tank weekly and vacuum weekly as well. I have 5 Juli, 4 Cherry Barb, 4 black skirts and 5 coral shrimp in the 29 gallon tank. I don't feel like this filter actually filters the water. When I stir up the tank the stuff that doesn't get in the vacuum tube, floats around and settles on everything. I never had that with the bio-wheel. What can I do to actually get this stuff to filter out? Do I need another filter solution. The sales guy talked me into the Fluval when I thought I wanted to move to a canister. I find that I have to vacuum after about 1 hour to get the bits up again. Super frustrated!
 
Sand
  • #2
el337
  • #3
You're actually underfiltered. For your tank size, you want at least 300 gph. The AC50 generates 200 gph which might be why you're not seeing it suck up enough. If you can, I'd upgrade to the AC70.
 
rossclan151
  • Thread Starter
  • #4
Hum.... the filter says on the package for 20-50 gallons. Bugger!! Okay, I am headed to the store today and will look into a bigger filter. I am also going to get one of those vacuums that has the filter bag and doesn't take the water out. Any experience with those?
 
el337
  • #5
Manufacturers tend to overestimate that on their filters. After all the media is added to filter box, it slows down the flow which is why you want to get one rated higher than your tank size.

No, I don't have experience with those vacs. You could always use a turkey baster.
 
rossclan151
  • Thread Starter
  • #6
Bought a power vacuum and thought I was going to vomit. The stuff it picked up blew me away. In fact there was so much stuff that it started blowing yuck out the side. Totally disgusting. Poor fish! I am going to get a bigger filter but now need to think canister or not.
 
clark12
  • #7
I have the aqua clear 20 on my 10 gallon and like how the media is set up... except there is no polish floss filter for the finer particles. I took out the carbon and put in purigen and a polishing filter pad I got from lfs. it was just hours and my water was sparkling.
 

Similar Aquarium Threads

Replies
5
Views
513
kuhlkid
Replies
7
Views
1K
A201
Replies
14
Views
3K
JimTheFishGuy
Replies
17
Views
4K
ForceTen
Replies
5
Views
740
boshk
Top Bottom