Floating Particles In New Tank

  1. Nichtor

    Nichtor New Member Member

    hi there! About 24 hours ago I completed setup of my new 55 gallon tank. There are no fish in there currently. The water was beyond cloudy when I filled it. I assume it's because of the sand I used. I though i washed it pretty thoroughly.. guess I missed a spot. So now 24 hours later the water is significantly clearer. When I saw how clear it was I started running my filter and the whole time I've been running my air stones. When I saw all the particles still there this morning I stopped running the filter which had only been on for an hour or so and I stopped the air stones that have been on since I filled it. I figured the moving water was not letting the particles sink or something. But I'm noticing a film on the top and if I do stern the water or plants or rocks at all dust comes off them and goes around the whole aquarium. I've also noticed large amounts of bubbles on the glass. Even when I wipe them off they come back pretty quick. Don't know what that's about. I have 5 live plants in there. Don't know if that has anything to do with anything. Everything seems to be covered in dust. Plants and rocks. Should I have my airstones on? Should I have my filter on? Do I just wait a while longer? Do I do a water change?? I am fairly new to fishkeeping. I have some experience and some limited knowledge but I'm just not sure about this! Any help would be greatly appreciated and thank you ahead of time to anyone who is kind enough to help me! :)
    Images:
     
  2. Fisher27

    Fisher27 Valued Member Member

    Lol, the reason there are more and more bubbles on the panes is because the filter is off. You have to let the filter run for a while. That's what happens when the water isn't circulating. Turn the filter on, you should never turn it off for too long.
     
  3. OP
    OP
    Nichtor

    Nichtor New Member Member

    The reason I had it off in the first place was because i was told the sand would ruin it. and not to run it till its clear. But ill turn it on again, Thank you!
     


  4. Fisher27

    Fisher27 Valued Member Member

    No problem!
     
  5. D

    Discusluv Well Known Member Member

    Welcome to fishlore! :)
    What kind of filter do you have? I use a pre-filter (sponge) that goes right over the filter outtake for the very same reason- so I dont get larger particles of food, sand, plant material going into my filter.
    By the way, you have done a great job planting and setting up your first aquarium- much better than my first aquarium a few decades ago.
     
  6. OP
    OP
    Nichtor

    Nichtor New Member Member

    Thank you for the kind words! I have a top fin power 40 on one side and a top fin power 80 on the other. so together thats 600 gph. But neither of them have any sponges on the filter. that would certainly be worth looking in to! Thanks again!
     
  7. D

    Discusluv Well Known Member Member