Filter Not Working Properly

  • Thread starter

Dandelion-Dream

Valued Member
Messages
214
Reaction score
66
Points
63
Experience
Just started
I've recently encountered an issue with my TopFin 10 gallon filter. It's been managing a heavy bioload for a year now, but just recently it's been acting improperly. The output has been reduced to a trickle, and I'm afraid this might impact my fish.
I have had some issues with brown algae in my tank, but nothing too serious for the most part.

Should I change the cartridge, take apart and scrub the inside of the filter, or fix any electrical problems? I'd like an upfront answer, I don't want my fish stewing in their own waste for too long.

NOTE: I am currently planning out a new, more spacious upgrade to resolve the overstocking issue. I would like to first fix my filter before discussing that.
 

TexasGuppy

Well Known Member
Messages
1,250
Reaction score
494
Points
83
Have you tried cleaning the filter? Could be growth in the impeller.. I would clean both.
 
  • Thread starter

Dandelion-Dream

Valued Member
Messages
214
Reaction score
66
Points
63
Experience
Just started
How would I clean the cartridge? Is rinsing it in tap water safe?
 

Fanatic

Fishlore VIP
Messages
9,164
Reaction score
6,149
Points
758
Experience
3 years
Dandelion-Dream said:
How would I clean the cartridge? Is rinsing it in tap water safe?
Rinse it in treated water, or tank water.
 
  • Thread starter

Dandelion-Dream

Valued Member
Messages
214
Reaction score
66
Points
63
Experience
Just started
Bump
I'd like some more input on this, just to be sure.
 

TexasGuppy

Well Known Member
Messages
1,250
Reaction score
494
Points
83
Easy to try to clean filter first, if it doesn't help enough, try the impeller. Or are you asking if you should just replace it?
 
Toggle Sidebar

Aquarium Calculator

Aquarium Photo Contests

Follow FishLore!





Top Bottom