Cycling Tank

Esli

Valued Member
Messages
295
Reaction score
61
Points
63
Experience
1 year
I am having no luck with my numbers lowering.
I have no fish in there only a sponge filter and a heater thats set up to 84.
Ive been cycling for over a month now.
My nitrates have been super high for about 2 weeks now. Doesnt seem like my nitrites are lowering either (they dropped a bunch within the past 3 weeks as it was super purple but since then nothing), if they are lowering I cannot tell & im dosing ammonia every time it drops to 0, adding just a bit for it to reach around 1ppm or slightly over.
Top picture is today
Bottom is over 2 weeks ago.
 

Attachments

  • Thread starter
  • Thread Starter
  • #5

Esli

Valued Member
Messages
295
Reaction score
61
Points
63
Experience
1 year
GreekGills said:
I had to do a few 50% water changes to knock down my nitrates, and once that happened, my cycle finished. I was dosing up to 2ppm ammonia as well.
Wow thanks, im going to try that because my nitrates are off the chart, its ridiculous. I figured it would need a little help. Thanks so much
 
  • Thread starter
  • Thread Starter
  • #7

Esli

Valued Member
Messages
295
Reaction score
61
Points
63
Experience
1 year
AquaticJ said:
How often are you dosing ammonia?
Im dosing every time it drops down which is like 24 hours.
This is the 3rd water change I've done. 50% of it and my nitrites are at the same number. I dont know what im doing wrong
 
Toggle Sidebar

Aquarium Calculator

Follow FishLore!





Top Bottom