Corals Not Blooming

Fishlover91
Member
Anya device on how to make my gsp and yellow toadstool leather bloom.


image.jpg
 
Ernest Sacco
Member
Fishlover91 said:
Anya device on how to make my gsp and yellow toadstool leather bloom.


image.jpg
First of all what are your parameters and how long have you been running the tank because from what the picture shows you have a serious hair algae problem which may be a result of high nutrients....it looks to me that the toadstool is in the process of shedding....you may want to get some more flow on him...I honestly can't tell in the picture where the gsp are even located



Never mind I see them in the front....yea without parameters it's difficult to make any assertion
 
  • Thread Starter
Fishlover91
Member
Ammonia: 0
Ph: 8.2
Nitrate: 0
Nitrite: 0
Salinity: 1.026
Tank has been running for around a year
And I don’t have a test for phosphate but I have a phosphate remover and the hair algae has been getting better
 
Ernest Sacco
Member
Fishlover91 said:
Ammonia: 0
Ph: 8.2
Nitrate: 0
Nitrite: 0
Salinity: 1.026
Tank has been running for around a year
And I don’t have a test for phosphate but I have a phosphate remover and the hair algae has been getting better
When did they start not extending or how long have they been in the tank...what type of flow do you have and lighting
 
Tony_097
Member
If your lighting and parameters are good the corals should be as well. Since the gha is taking up nitrates and phosphates try to remove as much as you can. After that do a water change.Water changes have saved me in the past and I will for the most part do water changes on a my sw tanks.
 
  • Thread Starter
Fishlover91
Member
I don’t know what kind of lighting or flow it is it came with the tank which is the fluval 13 gallon. Also not sure how long theya he’s been in the tank as I got the tank from someone else. I saw somewhere online today that you are supposed to feed the yellow leather toadstool, and haven’t been doing that because the person I got it from wasn’t doing that. I just removed a bunch of hair algae yesterday and recently got phosphate remover because again the person I got it fro didn’t have it.
 
Ernest Sacco
Member
Fishlover91 said:
I don’t know what kind of lighting or flow it is it came with the tank which is the fluval 13 gallon. Also not sure how long theya he’s been in the tank as I got the tank from someone else. I saw somewhere online today that you are supposed to feed the yellow leather toadstool, and haven’t been doing that because the person I got it from wasn’t doing that. I just removed a bunch of hair algae yesterday and recently got phosphate remover because again the person I got it fro didn’t have it.
You definitely want to look into researching as these corals need a certain level of light and flow to thrive....also do you have anything else in the tank that you are feeding....if not look into getting some nano fish to help generate a food source for the corals
 

Random Great Thread

Latest threads

Top Bottom