Cloudy water in new tank!

Discussion in 'Cloudy Aquarium Water' started by Deesk06, Jul 21, 2015.

  1. Deesk06Valued MemberMember

    I totally forgot to clean my substrate! It's a fine sand/gravel type thing. Will this be gone after I do some water changes? Or do I need to empty the whole thing ?


    Sent from my iPhone using Fish Lore Aquarium Fish Forum
     
  2. AquaticBrandon

    AquaticBrandonWell Known MemberMember

    Yeah it should go away after a few water changes. It also goes away on its own, it takes a few days. What kind of substrate was it? Just regular sand?


    Sent from my iPhone using Fish Lore Aquarium Fish Forum
     
  3. ClearEyes

    ClearEyesWell Known MemberMember

    Are you certain it's from the substrate? How established is your tank? It could be bacterial bloom, which is normal.

    I forgot to clean my substrate as well when I first started, and I didn't experience any ill effects.
     
  4. OP
    OP
    D

    Deesk06Valued MemberMember

    Yea I'm sure! Happened right away as soon as I added water to my tank!


    Sent from my iPhone using Fish Lore Aquarium Fish Forum
     
  5. OP
    OP
    D

    Deesk06Valued MemberMember

    It was like nat geo substrate! Not sure if it was sand..just very fine gravel


    Sent from my iPhone using Fish Lore Aquarium Fish Forum
     
  6. AquaticBrandon

    AquaticBrandonWell Known MemberMember

    It's normal, it should clear up in a few Days.


    Sent from my iPhone using Fish Lore Aquarium Fish Forum
     
  7. NylonFish

    NylonFishNew MemberMember

    My friend had the same problem with a 50g tank,it cleared up a few days after.


    :)
     




  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice