55 Gallon Tank Can anyone help me? Fish appears to have fungal/ bacterial infection

StickyFishy

So, a few weeks ago I added my first aquarium plant which was hornwort. I thought the plant would do fine and the silver dollar fish would not eat it-spoilers: they did. Then about maybe a week and a half later I had a black skirt tetra with long flowy fins slowly lose his fins to finrot and I figured he was pretty old and it might have been natural because none of the other fish were showing signs of anything wrong. Now my silver dollar seems to have some sort of infection and I cant tell what it is. My guess is a fungal infection/ bacterial infection that may have been brought in on the plant? I change the water every two weeks although last time I changed the tank (the 1st of may) I used a new strong water conditioner: API Tap Water Conditioner (super strength). I will probably do a water parameter check later and add it to this post.

P.S (the other silver dollar who looks fine is just for reference-there are two of them in the tank. There are a total of 10 fish in the tank.)
 

Attachments

  • 20210504_165404.jpg
    20210504_165404.jpg
    205.5 KB · Views: 17
  • 20210504_165442.jpg
    20210504_165442.jpg
    128.8 KB · Views: 18
  • 20210504_165355.jpg
    20210504_165355.jpg
    181.1 KB · Views: 20
  • 20210504_165414.jpg
    20210504_165414.jpg
    150.5 KB · Views: 19

StickyFishy

Nearly looks like ich....
I should note that, the shiny dots on his head are his scales and not little white dots that ich usually looks like.
 
Upvote 0

Similar Aquarium Threads

Replies
0
Views
81
kinsey12345
Replies
4
Views
77
A201
Replies
3
Views
113
DoubleDutch
Replies
7
Views
145
ZenKnight
Replies
1
Views
97
Tayler
Top Bottom