Brand New Aquaclear 50 Stopped Working

Discussion in 'Filters and Filtration' started by Kesh88, Jul 11, 2017.

  1. Kesh88

    Kesh88Valued MemberMember

    Help! I've just tried setting up my brand new Aquaclear 50 and it just stopped working! :-(

    I followed all the instructions, connected everything, filled the unit with water, plugged it in, it ran for about 2 minutes then just stopped. I noticed it was very rattly sounding when it was running but thought it might just need a few minutes to settle. I heard a click then it just stopped running :-/ when I unplugged it the motor unit was very hot. I've tried repositioning the impeller and plugging it in again but no luck :-(

    I'm not sure if it could be because the unit has an American plug and I'm using at adapter to an Australian plug? Did I fry the motor?
     
  2. Littlebudda

    LittlebuddaWell Known MemberMember

    This might sound stupid but have you tried plugging it into a different power socket? If it was pushing water it won't over heat, my ran for about 3 hrs without water last week and it was fine and it is over 25yrs old the aquaclear are a pretty solid unit they are hard to break
     
  3. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    Yeah I've tried a couple of sockets, no luck
     




  4. Littlebudda

    LittlebuddaWell Known MemberMember

    Where did you get it from amazon? I'd be looking for a refund. Can you turn the impeller when you have the motor off? Try plugging the motor in not on the filter and give the impeller a little flick to see if it starts up
     




  5. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    I got it from Amazon :-( nothing happens at all when I plug the motor in
     
  6. Littlebudda

    LittlebuddaWell Known MemberMember

    Sorry I can't help more I know mine was a bit noisey and kept stopping pumping when I first set it up but I just did those things I suggested and now it runs silently and strong
     
  7. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    Is the impeller meant to spin freely or just do a couple of rotations and stop when flicked?
     
  8. Littlebudda

    LittlebuddaWell Known MemberMember

    Yeah spin then stop it is a big magnet.

    Have you tried a different plug adapter?

    Also did you try plugging it in and giving the impeller a spin
     
  9. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    I think I've fried the motor, my fiance just gave me a lesson on 120 to 240v adaptors which I wasn't using!
     
  10. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    I want to cry, I just fried $70!
     
  11. Littlebudda

    LittlebuddaWell Known MemberMember

    Here is a link to new motors in Australia so it will avoid the problem
     
     
  12. OP
    OP
    Kesh88

    Kesh88Valued MemberMember

    Thanks :) I've already ordered a replacement from that site :)
     
  13. Littlebudda

    LittlebuddaWell Known MemberMember

    Good luck
     




  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice