Black Beard Algae In My Tank?

Kryptonian89

New Member
Member
Messages
9
Hello guys,

I’m totally lost on this. I’ve been fighting against what I believe is BBA for like 6 months with no success.

I don’t know what else to do.
I’ve even used Tetra Algae Control which killed all of the algae but 2 weeks later it came back.
I use Seachem excel daily too.

I hope you can help me as I’m desperate.

Fish:
6 neon tetra
2 Otocinclus
4 Red Cherry Shrimp

Tank: 5 gallon

Water parameters: attached (before water change)
Also I am including a couple of pictures of my tank.
IMG_1659.JPG
IMG_1658.JPG
IMG_1657.JPG
IMG_1656.JPG
IMG_1655.JPG
IMG_1654.JPG
 

Lucyn

Well Known
Member
Messages
545
Once BBA starts, you have to kill absolutely all of it and it will come back almost guaranteed if you don't. The extreme that some people go to is a Hydrogen Peroxide/Flourish Excel mix, spray it on the effected plants and it should completely die off within a week or two, typically. I had a pretty bad case one time, left the light off for almost a week and it all died out, if you think your plants could handle it that'd probably be the better solution because even I don't like to play around with chemicals. Your nitrates are also pretty high, that will fuel the algae for sure. Algae doesn't do so well in colder temperatures, if that helps.
 

New Threads

Similar Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
89
Guests online
2,016
Total visitors
2,105

Aquarium Photo Contests

Aquarium Calculator

Top Bottom