Awesome filter

captain jack
  • #1
I have a penguin 200 bio-wheel filter that has been nothing but trouble.tThe wheel always conkin out.Finally fed up with it I went and got the emperor line from the same manufacter a 280 to be excact..What a machine!!what more can a fishkeeper want...280 gph,extra clamshell for any media you desire,spray-bar,bio-wheel,easy access to everything,and pretty quiet too!!at this time both are running on just a 29 gal tank when my new one gets seeded that 200 is a goner...480 gph hmmm just a little over filtered???hehehe...just thought I would share this info if anyone was looking at this HOBow
 
Isabella
  • #2
I'm glad you like your new filter. Sounds very interesting
 
fishgirl
  • #3
Cant have to much filtering...the more the better
 
jsalemi
  • #4
Thanks for the report -- I've not had problems with the Penguin 100b I have on my 10g, but I got 2 Emperor 280s for my 56g (originally got an Emperor 400, but it didn't fit due to crossbar in the tank). They're waiting at home for me (along with my plants from liveaquaria), because I unfortunately had to go out of town suddenly due to a family emergency. We head home tomorrow, though, so I look foward to setting them up and getting them to filtering.
 
captain jack
  • Thread Starter
  • #5
It seems that since the new filter that it has split the load on the 200 and now it's working ok,But I still don't quite trust it as of yet.jsalemI I think you will like that filter, mine is doing a bang up job and I think it will perform perfectly for you but of course with proper cleanings it should last quite awhile.
 
jsalemi
  • #6
Got them going tonight -- took a while for them to settle down and get a good suction going, but once they did I can barely hear them, and I'm sitting less than 6 feet away. I think I'm going to be very happy with them.
 
captain jack
  • Thread Starter
  • #7
SWEET!! I like the little babbling brook sound the spray-bar makes.I may be new to fish keeping but I know good stuff when I see it..May your fish live long and be happy!!x
 
MudHog
  • #8
I have a Emperor 280 on my 39g tank. At first I liked it, but now I'm starting to dislike it. I had some trouble with it not pulling a suction. Took it to my LFS and it worked perfect for them. Brought it back home and it's been working. I need to go back to my LFS and check the output of another one, I just feel I don't have much flow with this one and it has slowed down. I bought a small filter from Wal-MArt while back when I first had trouble and it has substantial more water flow.
 

Similar Aquarium Threads

  • Locked
Replies
10
Views
8K
chadwick61
Replies
28
Views
3K
Islandvic
  • Locked
Replies
10
Views
979
Jaq
Replies
9
Views
840
Liability
Replies
8
Views
2K
rmurray
Top Bottom