Aqueon Quietflow 50 Not Working.

Discussion in 'Filters and Filtration' started by Taylor Jenson, Apr 10, 2017.

  1. Taylor Jenson

    Taylor JensonValued MemberMember

    My 1 week old, just tried today, quietflow50 filter is not working. What i mean by that is that the filter won't pump water. After unplugging and re-plugging it for awhile, it worked, no strange noises, and after that it stopped working.

    The filter is in my new 29 gallon tank. For this tank I am using pool filter sand, but there is an AquaClear sponge over the intake. I placed another sponge in an empty space in the media area. Is this the problem? I tried removing it, but the results were the same.

    I ordered the filter off of amazon, so Im really hoping this is a fixable problem.

    [​IMG][​IMG][​IMG]

    (Sorry the tank is blurry. Added the sand today)
     
  2. Bizarro252

    Bizarro252Well Known MemberMember

    The impeller could just be stuck, pull the intake tube out and grab a pen or something to just push the impeller a bit one way or the other then plug it back in. Mine would do this if I didnt keep up on cleaning the magnet.
     
  3. MD_Plants

    MD_PlantsWell Known MemberMember

    you could always complain to amazon seller and get a replacement or refund
     
  4. MD_Plants

    MD_PlantsWell Known MemberMember

    also, pool sand in a new tank like your still has sand partials in the water. sand might have gotten sucked into filter and jammed the propeller. so try to spin it. it you hear grinding chances are it is jammed with sand. gl!
     
  5. Bizarro252

    Bizarro252Well Known MemberMember

    Also, if you have not got to far along yet, you may want to pull that sand out and rinse it some more. I just swapped to pool sand, it took TWO HOURS but I got it rinsed to the point where there was zero cloudyness.
     




  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice